Community
cancel
Showing results for 
Search instead for 
Did you mean: 
ASath1
Beginner
1,007 Views

i354 autoneg-off link issue

Hi,

I am observing a strange issue with i354 when auto-negotiation is turned off.

The device I have has 6 ethernet ports. Port 1 and 2 are based on i210 and port

3 to 6 are based on i354 (connected thru an external PHY). The CPU is Atom

Rangeley (4 core).

I have connected ports 3 and 4 back to back with an external cable. When the

 

link is forced to 100M/Full duplex with auto-negotiation off on both the ports,

 

the link does not come up.

 

 

Whereas the link comes up fine when eth3 (i354) and eth1 (i210) are connected

 

back to back and forced to 100M/Full duplex with auto-negotiation off.

 

 

This issue is seen with DPDK (16.04) and also linux kernel (ubuntu 14.04).

 

 

Is this a known issue ?

 

 

Following are logs when running the test using ethtool from linux

 

 

admin@Ananda-Desk:~$ lspci | grep Ethernet

 

00:14.0 Ethernet controller: Intel Corporation Ethernet Connection I354 (rev

 

03) - eth2

 

00:14.1 Ethernet controller: Intel Corporation Ethernet Connection I354 (rev

 

03) - eth3

 

00:14.2 Ethernet controller: Intel Corporation Ethernet Connection I354 (rev

 

03) - eth4

 

00:14.3 Ethernet controller: Intel Corporation Ethernet Connection I354 (rev

 

03) - eth5

 

01:00.0 Ethernet controller: Intel Corporation I210 Gigabit Network Connection

 

(rev 03) - eth0

 

02:00.0 Ethernet controller: Intel Corporation I210 Gigabit Network Connection

 

(rev 03) - eth1

 

 

admin@Ananda-Desk:~$ ethtool -i eth3

 

driver: igb

 

version: 5.2.13-k

 

firmware-version: 0.0.0

 

bus-info: 0000:00:14.1

 

supports-statistics: yes

 

supports-test: yes

 

supports-eeprom-access: yes

 

supports-register-dump: yes

 

supports-priv-flags: no

 

 

[Force 100M/Full on eth3]

 

 

admin@Ananda-Desk:~$ sudo ethtool -s eth3 autoneg off duplex full speed 100

 

 

admin@Ananda-Desk:~$ ethtool eth3

 

Settings for eth3:

 

Supported ports: [ TP ]

 

Supported link modes: 10baseT/Half 10baseT/Full

 

100baseT/Half 100baseT/Full

 

1000baseT/Full

 

Supported pause frame use: Symmetric

 

Supports auto-negotiation: Yes

 

Advertised link modes: Not reported

 

Advertised pause frame use: Symmetric

 

Advertised auto-negotiation: No

 

Speed: 100Mb/s

 

Duplex: Full

 

Port: Twisted Pair

 

PHYAD: 1

 

Transceiver: internal

 

Auto-negotiation: off

 

MDI-X: off (auto)

 

Cannot get wake-on-lan settings: Operation not permitted

 

Current message level: 0x00000007 (7)

 

drv probe link

 

Link detected: yes

 

 

admin@Ananda-Desk:~$ ethtool eth4

 

Settings for eth4:

 

Supported ports: [ TP ]

 

Supported link modes: 10baseT/Half 10baseT/Full

 

100baseT/Half 100baseT/Full

 

1000baseT/Full

 

Supported pause frame use: Symmetric

 

Supports auto-negotiation: Yes

 

Advertised link modes: 10baseT/Half 10baseT/Full

 

100baseT/Half 100baseT/Full

 

1000baseT/Full

 

Advertised pause frame use: Symmetric

 

Advertised auto-negotiation: Yes

 

Speed: 100Mb/s

 

Duplex: Half

 

Port: Twisted Pair

 

PHYAD: 2

 

Transceiver: internal

 

Auto-negotiation: on

 

MDI-X: on (auto)

 

Cannot get wake-on-lan settings: Operation not permitted

 

Current message level: 0x00000007 (7)

 

drv probe link

 

Link detected: yes

 

 

 

[Force 100M/Full on eth4]

 

 

admin@Ananda-Desk:~$ sudo ethtool -s eth4 autoneg off duplex full speed 100

 

admin@Ananda-Desk:~$

 

admin@Ananda-Desk:~$ ethtool eth4

 

Settings for eth4:

 

Supported ports: [ TP ]

 

Supported link modes: 10baseT/Half 10baseT/Full

 

100baseT/Half 100baseT/Full

 

1000baseT/Full

 

Supported pause frame use: Symmetric

 

Supports auto-negotiation: Yes

 

Advertised link modes: Not reported

 

Advertised pause frame use: Symmetric

 

Advertised auto-negotiation: No

 

Speed: Unknown!

 

Duplex: Unknown! (255)

 

Port: Twisted Pair

 

PHYAD: 2

 

Transceiver: internal

 

Auto-negotiation: off

 

MDI-X: on (auto)

 

Cannot get wake-on-lan settings: Operation not permitted

 

Current message level: 0x00000007 (7)

 

drv probe link

 

Link detected: no <<<<<<<<<<<<<<<p> admin@Ananda-Desk:~$ ethtool eth3

 

Settings for eth3:

 

Supported ports: [ TP ]

 

Supported link modes: 10baseT/Half 10baseT/Full

 

100baseT/Half 100baseT/Full

 

1000baseT/Full

XXXWHITESPACEXX...

0 Kudos
1 Reply
AlHill
Super User
93 Views

Are you related to this identical post:

One thread is enough. Choose one and stay there.

Doc

Reply