Ethernet Products
Determine ramifications of Intel® Ethernet products and technologies
All support for Intel NUC 7 - 13 systems has transitioned to ASUS. Read latest update.
4756 Discussions

iSCSI boot rom not working?


Hi, I have a 1000 PT card with 14.7 iscsi boot installed and an Asus P5B with latest BIOS.


When I boot the computer, I can configure the network card with CTRL-D, but when I try to boot from iscsi, nothing happens. I can see the MAC address of the card briefly, and then it just hangs.

The last line on the screen is now: Press Esc key to skip iSCSI boot initialization.

No matter how long I wait or what I press, nothing happens anymore.

I would like to be able to use iscsi boot on this board to boot diskless RedHat5.4 but it never seems to access the iscsi lun.

I have configured the card with an IP address, but I also can't ping it from another host. The link lights are on.

I also tried this on a gigabyte EX58-UD5 mainboard with i7-920 and get very unreliable results. A few times I can see it connect to the iscsi lun, but other times it also just hangs.

In the p5b, there are no other cards other than the video card. onboard sata and networking is disabled in bios.

Are other people using iscsi boot successfully?



0 Kudos
3 Replies

Try checking on switch setting as well. What is the switch model used? have you tried connecting to another brand of switch for testing? Used to encounter issue unable to connect even when using static IP. Tried changing the connection to another switch then it worked. Not sure if this is applicablicable to your case..


Hi Frank,

The most likely cause for this issue is a link failure during the LUN connection phase. This could be caused by speed/duplex missmatch, faulty cable, or switch port issue. Make sure the switch port is set to Autonegotiate. If it is already set to Auto, then swap out the cable with one that has known to work in the past. If the issue still persists then can you try another switch port?

If this is a dual port NIC, you can try to assign the other port as "secondary" in the iSCSI boot configuration screen. If you see a message that the secondary port is being used then that would tell us that there is something wrong with the primary port, cable, or switch port.



Hi, will try at home with another switch.

I tried the card in an HP desktop pc (using a different switch) and it seemed to work there. Still not sure if this was caused be the switch or mainboard bios.

Thanks for your suggestions so far, will do some more testing.

With kind regards,