Ethernet Products
Intel® Ethernet products and technologies
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
3969 Discussions

ixgbe allow_unsupported_sfp no longer works

ELu14
Beginner
2,577 Views

I have run " modprobe –r ixgbe && modprobe ixgbe allow_unsupported_sfp=1" to enable allow_unsupported_sfp after upgrading the ixgbe driver to v3.17.3. Unfortunately, I still got "failed to load because an unsupported SFP+ module type was detected" issue. Do we need to reboot the server to apply modprobe?

0 Kudos
1 Reply
YAdam1
Beginner
1,290 Views

Just in case anyone comes looking here, the possible solution to the above is to use:

modprobe ixgbe allow_unsupported_sfp=1,1

 

As in: you have to spell out allow for both ports in the case of an 82599 NIC for example.

 

It must seem obvious to most since it's barely mentioned anywhere but hey... modinfo DOES say it's an array

 

parm: allow_unsupported_sfp:Allow unsupported and untested SFP+ modules on 82599 based adapters, default 0 = Disable (array of int)
Reply