Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
347 Views

x710 HP OEM (HPE 10Gb 2-port 562SFP+) LLDP not working on some ports

Hello,

 

we have two HP DL380 Gen10 Servers with HP branded Intel x710 dual port cards.

 

HPE 10Gb 2-port 562SFP+

 

OS is VMware ESXi 6.7 U3.

 

 

We have disabled LLDP on the driver with the following command:

 

esxcli system module parameters set -m i40en -p LLDP=0,0

On the network side, we have two Cisco Nexus 9300 switches.

We have configured an EtherChannel with two switch ports, one port on each switch.

 

On the ESXi hosts, we have a distributed vSwitch with two uplinks.

Each uplink is part of the EtherChannel.

Each uplink is on a seperate HPE 10Gb 2-port 562SFP+ NIC.

 

And here comes the issue: LLDP is only working on one port of the first NIC. LLDP is completely disabled on the second NIC.

 

When we switch the NICs in the riser cards, the issue stays on the PCIe slot, so it seems, that it´s not a hardware issue with the NICs.

 

When we establish an EtherChannel on two ports of the same NIC, LLDP works.

 

HP and VMware support was not helpful. VMware does not give any support, because it´s an OEM NIC and HP says it´s not a driver/firmware issue and we should contact VMware.

 

Any ideas to get this working?

 

Are EtherChannel and LLDP over more than one physical NIC supported with a distributed switch?

 

Thanks in advance!

0 Kudos
5 Replies
Highlighted
124 Views

Hello MPH,

 

Thank you for posting in Intel Ethernet Communities. 

 

While we are checking your query, we'd like to confirm if you have tried posting the question on VMware communities link below? If yes, kindly share their feedback with us.

https://communities.vmware.com/welcome

 

Looking forward to your reply.

 

In case we don't hear from you, we'll follow up after 3 business days.

 

Best regards,

Crisselle C

Intel® Customer Support

0 Kudos
Highlighted
124 Views

Hello MPH,

 

Good day!

 

We'd like to follow up the requested information for us to further check on your request.

 

Awaiting to your response.

 

Should there be no reply from you, we'll follow up after 3 business days.

 

Best regards,

Crisselle C

Intel® Customer Support

0 Kudos
Highlighted
124 Views

Hello MPH,

 

Appreciate your patience on this matter.

 

Sharing the Intel® ESXCLI Plug-In (link below) with you. Please try to use it to disable the LLDP on your 2 HPE 10Gb 2-port 562SFP+.

https://downloadcenter.intel.com/download/28479/Intel-ESXCLI-Plug-In-for-Managing-Intel-Ethernet-Net...

 

Use the following commands found in the readme file of Intel® ESXCLI Plug-In for Managing Intel® Ethernet Network Adapters:

https://downloadmirror.intel.com/28479/eng/intnetcli-esx67-readme.txt

 

Disable the LLDP agent with the command below:

esxcli intnet fwLldpAgent set -s disable -n vmnic0

 

Check the status of the LLDP agent with the command below:

esxcli intnet fwLldpAgent get -n vmnic0

 

The vmnic0 is the device listed by the network NIC list command. For your case, this should be the HPE adapter port wherein you would like to disable the LLDP functionality.

 

Please share the results with us once you’ve tried it out.

 

We look forward to your response.

 

In case we don’t hear from you, we’ll follow up after 3 business days.

 

Best regards,

Crisselle C

Intel® Customer Support

 

0 Kudos
Highlighted
124 Views

Hello MPH,

 

Good day!

 

We'd like to check if you have received our previous message and if you were able to try it out? If yes, kindly share some update on this thread.

 

Awaiting to your reply.

 

Should there be no response from you, we'll follow up after 3 business days.

 

Best regards,

Crisselle C

Intel® Customer Support

0 Kudos
Highlighted
124 Views

Hello MPH,

 

How are you today?

 

Please be informed that we will now close this request since we haven't received any response from our previous follow ups. Just feel free to post a new question if you may have any other inquiry in the future.

 

May you have a lovely day!

 

Best regards,

Crisselle C

Intel® Customer Support

0 Kudos