Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
1,003 Views

8E1111 PHY tx_clk and rx_clk

Hi, 

 

I have a custom board with altera Stratix 4 and 8E1111 PHY. i am trying to initiate the triple speed ethernet IP. a 25MHz crystal is connected with the PHY.  

i have used the Simple Socket Server Software Example to initiate the IP.  

 

i have tried to probe the tx_clk and rx_clk, clock signals from PHY. there is no clock coming from PHY.  

is there any initiation needs to be performed to start the clock from PHY? 

 

Thanks 

Vinay
0 Kudos
5 Replies
Altera_Forum
Honored Contributor I
25 Views

Are you setting the Phy interface to RGMII? 

 

https://www.altera.com/support/suppo...62011_851.html
Altera_Forum
Honored Contributor I
25 Views

No. i am trying to set it for GMII/MII mode. 

 

the link you posted is not working.
Altera_Forum
Honored Contributor I
25 Views

My point was that you may have to set the interface you want. Try this link: 

 

https://www.altera.com/support/support-resources/knowledge-base/solutions/rd07082013_58.html 

 

Do you have a data sheet for the 88E1111?
Altera_Forum
Honored Contributor I
25 Views

Thanks for the link.  

if i am following this configurations, how can i verify the setting?  

i want to initiate the MII interface. can i check the behavior by probing the tx_clk/rx_clk signals?
Altera_Forum
Honored Contributor I
25 Views

Hi, 

 

I just figured out that in the config[4] of 8e1111 connected to ground. so i think PHY is getting initialized in RGMII mode. is that true? 

 

Thanks 

Vinay
Reply