Community
cancel
Showing results for 
Search instead for 
Did you mean: 
zeahr
Beginner
991 Views

ASMI Parallel II elaboration error

Jump to solution

Hi,

 

I tried to simulate the Quartus generated testbench of ASMI Parallel II ip core but there is an error during elaboration.

I am using Modelsim DE 10.6a running on Linux, and I am using Quartus Prime Standard 18.1 running on Windows 10.

I copied the testbench folder of ASMI ipcore to the Linux workstation, also I copied all the necessary library (./eda/sim_lib/) that are listed in the msim_setup.tcl and modified the "$QUARTUS_INSTALL_DIR" and point to correct library source file.

"dev_com" and "com" works successfully but there is an error during "elab_debug" command.

 

* Error: (vsim-3033) <protected>(<protected>): Instantiation of '<protected><protected><protected><protected><protected><protected>' failed. The design unit was not found.

#  Time: 0 ps Iteration: 0 Protected: /ASMI_CORE_tb/asmi_core_inst/asmi_parallel2_top_0/asmi2_core/asmi2_qspi_interface_0/dedicated_interface/genblk1/dut_asmiblock/inst/<protected> File: nofile

 

Does anyone encountered this problem?

 

Thank you.

Best Regards,

Zeahr

0 Kudos
1 Solution
Nooraini_Y_Intel
Employee
213 Views

Hi Zeahr,

 

You can try use the MT25QL256 (Micron's QSPI flash) simulation model as we are going to support MT25Q flash due to the EPCQ256 EOL announcement here. There are no EPCQ simulation model files available.

https://www.intel.com/content/www/us/en/programmable/support/support-resources/knowledge-base/compon...

 

Regards,

Nooraini

 

View solution in original post

5 Replies
Nooraini_Y_Intel
Employee
213 Views

Hi Zeahr,

 

Did you turn on the "Enable flash simulation model" option? As far I know, this error can be seen when the “Enable simulation” parameter is enabled but there are no FLASH model inside. When user check "Enable simulation" parameter during IP generation, asmiblock model expect "asmi_sim_model" module should be there to connect with flash model. You need to include the flash device simulation model files.

 

If you want to simulate just the IP without the flash model, you can turn off the “Enable simulation” parameter during IP generation. However, this will cause some operation not able to simulate such as “read_status” and "read_rdid" as this required information from flash. 

 

You can refer to the following how to video on simulating ASMI block:

https://www.youtube.com/watch?v=kxNDMSUQt1Q

 

Regards,

Nooraini

zeahr
Beginner
213 Views

Hi Nooraini,

 

Thank you for your reply.

Yes, I did turned on the "Enable flash simulation model" option.

Where can I download the EPCQ256 simulation model? I cannot find it in Intel website.

Should I use a third party model (i.e. Micron's Serial flash)? if yes, what device is compatible to EPCQ256?

 

Thank you.

 

Best Regards,

Zeahr

AnandRaj_S_Intel
Employee
213 Views

Hi Zeahr,

 

Have you enabled the enable_sim parameter?

Error is due to Version & environment comparability

To avoid error by

  1. You have to use same environment from project creation and simulation.
  2. Appropriate modelsim to be used with respect to Quartus version.

 

I was able to simulate successfully using Quartus 18.1 Std & Modelsim SE 10.5b in windows 10 environment.

Attached the transcript and image for reference.

Let me know if this has helped resolve the issue you are facing or if you need any further assistance.

 

Best Regards,

Anand Raj Shankar

(This message was posted on behalf of Intel Corporation)

asmi_sim.jpg

 

Nooraini_Y_Intel
Employee
214 Views

Hi Zeahr,

 

You can try use the MT25QL256 (Micron's QSPI flash) simulation model as we are going to support MT25Q flash due to the EPCQ256 EOL announcement here. There are no EPCQ simulation model files available.

https://www.intel.com/content/www/us/en/programmable/support/support-resources/knowledge-base/compon...

 

Regards,

Nooraini

 

View solution in original post

zeahr
Beginner
213 Views

Hi Nooraini,

 

Thank you for your advice.

The elaboration completed successfully.

 

Thank you.

Best Regards,

Zeahr

Reply