Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
835 Views

DSP builder IP generator error

Hi, 

 

I am using DSP builder 9.1, 10.0. 

 

I added the FFT mega core to my simulink model the regular IP generator  

GUI. When I double click it again, I rceive the following message in MATLAB: 

 

> unable to locate the megacore variation file [path] in directory [path] 

> ip toolbench is using a default variation file for the fft megacore 

 

 

Can anyone tell me why this happens? If not, can anyonw tell me what is the "variation file"? 

 

I susspect that this message has something to do with an error message I receive in the Quartus project I build using the files DSP builder ceated.  

 

The Quartus error I receive is: 

 

Error: IP Generator Error: Entity '' (Version latest) not found in librarian. 

 

I found a note in the Altera Web site regarding this issue (http://www.altera.com/support/kdb/solutions/rd05022008_910.html)  

 

but it is not relevant to me, as I do not have such a folder (.altera.quartus). (could this be the problem?) 

 

Any help to at least of the above question will help me a lot. 

 

Thank you in advance, 

 

Gilad
0 Kudos
10 Replies
Altera_Forum
Honored Contributor I
49 Views

When you have more than 1 version of DSP builder, things often goes wrong, and so your problem could be one of those issues.  

 

If you instantiated FFT using 9.1 you can’t open the core again using 10.0 and vice versa. 

You need to make sure your environment and the core versions match. 

 

The command to check is (type it at the matlab prompt): 

getenv('QUARTUS_ROOTDIR') 

 

and you need to check if the folder matches the version of your FFT in your design.  

 

There are a few ways to set it correctly if it is wrong, but what I normally do is  

1/ close Matlab 

2/ open the Quartus II version that I intend to use for DSPB.  

3/ Open matlab again, and type getenv('QUARTUS_ROOTDIR') 

This normally sets the environment to the right version.  

 

The design still fails after the version is set correctly correct, then what I would then do is to change the order of the path settings.  

 

1/ from Matlab menu File->Set path, you will see lots of paths set here.  

For example if you had 9.1 and 10.0 versions, you would see folders like: 

 

- c:\altera\10.0\quartus\dspba\Blocksets, etc 

- c:\altera\9.1\quartus\dspba\Blocksets, etc 

 

2/ highlight all the folders belonging to the particular version you want to use if they are below the other version folders, and then click on Move to Top. Save and close. To be doubly sure, I would close matlab and start up again although mathworks says the change will be effective immediately.  

 

Having said that, as mentioned earlier, having more than 2 versions of DSPB always is somehow troublesome, so you should bear it in mind…
Altera_Forum
Honored Contributor I
49 Views

Hi, 

 

Thank you for your reply. I do not use two DSP builder versions on the same machine. In addition. I do not use two Quartus versions on the same machine.  

 

I tried the following your advises, but all paths are defined properly. Still, this error appears. Anyone knows why?
Altera_Forum
Honored Contributor I
49 Views

Found the problem. The problem was due to Quartus not finding the correct the ".ipx" file, which points to the FFT MegaCore generated files (the "...Import" folder). This is weird because the path was defined in the project properties, but for some reason Quartus needs another ".ipx" file, which points to the needed ".ipx", before he uses it.  

 

Anyway, in case someone from Altera reads this, the error message Quartus outputs  

(Error: IP Generator Error: Entity '' (Version latest) not found in librarian.) 

 

is very misleading. I suggest chagning it to a more inofrmative one 

 

Gilad
Altera_Forum
Honored Contributor I
49 Views

Hi gilkal 

 

I have the same error, could you please explain in more details how you solved it ? 

 

Thanks 

Ahmed
Altera_Forum
Honored Contributor I
49 Views

Hi Ahmed, 

 

I can tell you what was the problem with my appliation- I hope it will be relevant to yours. 

 

The altera IP generator creates different files. One of these files has the ".ipx" extension. If, for some reason, a Quartus project that uses the IP cannot find a file with that extension (.ipx) Quartus will give the following error message:  

(Error: IP Generator Error: Entity '' (Version latest) not found in librarian.) 

 

I personaly think this message is misleading, and I have spent quite some time before finding the answer. I wrote in my previous message that I think they should do something about this error message but appearently Altera does not feel the same (or nobody there knows about this problem). 

 

I can also say that I saw this error message when there was a difference between the two versions (for example: using Quartus 7.2 with IP core 6.1). It happend on and old version and I do not not if this still applies now. 

 

I hope I helped a little 

 

Godd luck, 

 

Gilad
Altera_Forum
Honored Contributor I
49 Views

Hi Gilad 

 

Thanks for your fast response. 

 

So, what do you think I have to do with the .ipx file to solve the problem ? 

 

Thanks 

Ahmed
Altera_Forum
Honored Contributor I
49 Views

Yes, I think you should try verifying that Quartus has included the".ipx" file in his serach path. I think it is generated under a folder called "IP". See in your Quartus project settings that it is pointing to that ipx file. If that does not work you should see if there are different versions of Quartus/IP, as mtjp answered in one of the previous answers

Altera_Forum
Honored Contributor I
49 Views

I don't use Quartus with my design. I just open Matlab and the dsp builder blocks are there then I compile it. How does Quartus appear in that ?

Altera_Forum
Honored Contributor I
49 Views

I add the files DSP builder generates with my Quartus project. Did you follow the instructions of the IP core user manual? Maybe you could try to reconfigure the IP block by double clicking on it- that way it's files will be updated.  

 

Anway, here's a link to an offical Altera solution to a problem such as this. I did not help me with my problem, prehaps it will help you 

 

http://www.altera.com/support/kdb/solutions/rd05022008_910.html
Altera_Forum
Honored Contributor I
49 Views

Thanks a lot for you help. 

 

It is working now. The problem was that some VHDL files in the model were not compiled. when I used the command "alt_dspbuilder_refresh_HDLimport" in Matlab command window, it compiled all the VHDL files of the design and it worked. 

 

Thanks again for you help. 

 

Thanks 

Ahmed
Reply