FPGA Intellectual Property
PCI Express*, Networking and Connectivity, Memory Interfaces, DSP IP, and Video IP
All support for Intel NUC 7 - 13 systems has transitioned to ASUS. Read latest update.
6324 Discussions

Do somebody tryed to use Reed Solomon Encoder/Decoder II?

Honored Contributor II



Do somebody tryed to use Reed Solomon Encoder/Decoder II? 


I've used RS Compiler I and had no any problems with it. 


But now I am trying to use Reed Solomon Encoder/Decoder II on Quartus 11.1 and have considerable troubles. 


1) First, it don't want to be simulated in Modelsim (I am using Modelsim ASE 10.1). 

When Nativelink creates .do file for Modelsim, this file contains references for files of the simulation models, that are not exists (for example, "RS_EncoderII.vo"). So Modelsim outputs error "Can't find file". 


This problem had beed solved by creation of my own .do file for Modelsim where the proper files are listed. 


2) Second, Encoder II' and Decoder II' simulation models contain file/module with the same name, "altera_rs_ii_0001.v". 

So, when the project contains both Encoder II and Decoder II, Modelsim tryes to use one file for both Encoder and Decoder, so outputs error. 


This problem has been solved by renaming the file/module "altera_rs_ii_0001.v" so that they have different names for Encoder and Decoder. 


3) After problems 1) and 2) had been solved, simulation began to work! 

But Decoder works incorrectly in the simulator: 

1. No sop and eop signals (they are always 0). 

2. Error outputs shows some incomprehensible when errors are exists (I am inputting little amount of errors). 

3. Errors are go to output (no correction made or not always). 


Did somebody tryed to use these IPs? 

Did you had the same problems? 

If yes, how did you solved them? 


Thank you in advance for answers.
0 Kudos
0 Replies