FPGA Intellectual Property
PCI Express*, Networking and Connectivity, Memory Interfaces, DSP IP, and Video IP
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
5920 Discussions

Error (292019): Core PCI Express Compiler (6A66_00A9) is not enabled

Altera_Forum
Honored Contributor II
1,238 Views

I'm trying to reuse and old design which was on Cyclone 2 which had PCIe. I used Quartus 2 to synthesize the design on Cyclone 4 GX device. I get an error during compilation- 

 

Error (292019): Core PCI Express Compiler (6A66_00A9) is not enabled for current device family 

 

I tried on Stratix 4 GX and GT as well and get the same error. 

 

Please suggest how to resolve this compilation issue for PCI Express compiler. 

 

Thanks and Regards, 

 

Sameer.
0 Kudos
2 Replies
Altera_Forum
Honored Contributor II
151 Views

What is your quartus version? Do you change manually the target device in PCIE to cyclone IV in the megawizard?

Altera_Forum
Honored Contributor II
151 Views

6A66_00A9 refering to PCIe Soft IP which required a valid license. 

From the error message, it indicates that your previous PCIe soft IP license file was expired and can't be used in newer device.
Reply