FPGA Intellectual Property
PCI Express*, Networking and Connectivity, Memory Interfaces, DSP IP, and Video IP
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
5875 Discussions

I2C 'functions' with LEDs, not with PMODA port

Altera_Forum
Honored Contributor I
782 Views

I'd like to use the I2C interface so I used the 'I2C Master'in Qsys.  

I route the SCL and SDA outputs of the core to two GPIO pins of the 

PMODA connector of my Max 10 Development Kit board. This does not work.  

Nooutput from the pins at all.  

 

Strangely enough, if I replace the two pins by twoon board LEDS  

the latter light up, indicating that there are SCL and SDAsignals  

getting generated.  

 

Any idea how to get the PMODA working? I checked PMODA  

independently with almost the same setup and it works fine. 

 

This is the LED-code in the Verilog-file: 

 

.i2c_opencores_0_export_sda_pad_io (USER_LED[2]) 

.i2c_opencores_0_export_scl_pad_io(USER_LED[3])  

 

And of course very similar for the PMODA port: 

 

.i2c_opencores_0_export_sda_pad_io(PMODA_IO[6])  

.i2c_opencores_0_export_scl_pad_io (PMODA_IO[7])  

 

Thanks in advance, 

Jos
0 Kudos
2 Replies
Altera_Forum
Honored Contributor I
95 Views

You may want to add pull-up resistors to the sda and scl pins.

Altera_Forum
Honored Contributor I
95 Views

Thanks! When I read your reply I was just busy doing this and it works. 

That is, I see activity on the pins. Now I can continue to work on the 

I2C expander I use the I2C signals for. 

 

Jos
Reply