Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
2,455 Views

IP upgarde required

Hi, 

 

I have installed Quartus Prime and using DE0 nano development board. When I add the LPM_MUX from the IP catalogue I have a red message "IP UPGRADE REQUIRED". 

Pressing the button brings up a dialog button to launch the IP Upgrade tool. Please see attached screenshot. 

 

I have used the 'upgrade in editor' and 'generate simulator script for IP' buttons. The regeneration status was successful, but I still have the red message "IP UPGRADE REQUIRED". 

 

If I hover my mouse over the error it states "Compilation of IP is not supported in current software version". I have the latest version of quartus prime downloaded yesterday... 

 

I'm wondering if someone else has seen this problem and has an idea what I need to do? 

 

Many thanks for your time. 

 

Best Regards 

Peter Mayhew 

 

PhD Research Student 

University of the West of England
0 Kudos
10 Replies
Altera_Forum
Honored Contributor I
146 Views

I believe I have worked out the issue. The IP catalogue requires a licence, so I need to right click the screen and insert a megafunction. 

 

I'm sure Quartus II used to run a wizard for the megafunctions, but in Quartus Prime, it just inserts the symbol and doesn't run a wizard.
Altera_Forum
Honored Contributor I
146 Views

I recently ported a project from quartus II to Pro with over 100 ips and came across several issues. I had most ips upgraded automtically once project opened as it prompts "upgrade ip". Some ips failed asking me to compile them in qsys GUI individually (automatic script does not support some ips). For example fft cores have to be opened in qsys and then regenerated. You may need to close/open project or do project clean up for these tool glitches to disappear.

Altera_Forum
Honored Contributor I
146 Views

Thank you. I am using the lite edition of Quartus Prime. Is the IP catalogue limited to the standard edition?

Altera_Forum
Honored Contributor I
146 Views

Also be aware that Quartus Pro ips are generated with their absolute paths added to qsf instead of relative path. This is a problem in team work using version control.We raised the issue to Altera [sorry I mean Intel] and they sent us a patch but it didn't work and now the patch needs a patch.

Altera_Forum
Honored Contributor I
146 Views

 

--- Quote Start ---  

Thank you. I am using the lite edition of Quartus Prime. Is the IP catalogue limited to the standard edition? 

--- Quote End ---  

 

 

So sorry I am really confused between these versions and their names. I haven't used lite edition
Altera_Forum
Honored Contributor I
146 Views

That's ok. I think it's because I am using the free (lite version). Have a great day. 

 

Peter
Altera_Forum
Honored Contributor I
146 Views

All basic IPs like this should work OK in the Lite edition without licensing. The IP base suite, however, does require licensing in the lite edition (https://www.altera.com/products/intellectual-property/design/ip-base-suite.html). I'm not sure why you are having this issue. Are you saying you get the error as soon as you add the IP from the IP catalog?

Altera_Forum
Honored Contributor I
146 Views

Yes that is correct.

Altera_Forum
Honored Contributor I
146 Views

Hi all :) 

 

I am also having the same issue.  

it occurs after i edit a symbol in the parameter editor again.
Altera_Forum
Honored Contributor I
146 Views

Hi All, 

1. Clean the project 

2. Remove the old .qip file from the ip directory 

3. Regenerated the IP using Qsys or new Platform Designer 

 

this worked for me :)
Reply