Community
cancel
Showing results for 
Search instead for 
Did you mean: 
LBrad5
Beginner
401 Views

Issues with SDI Audio Embed IP

I am evaluating the SDI IP and I have a couple of issues regarding the use of the Audio Embed IP.

 

  1. It is not possible to embed group 2, 3 or 4 independently unless group 1 is enabled first. This behaviour is only seen on HD/3G. SD seems to allow this.
  2. I have generated the core to include 24-bit support for SD-SDI and have set the register bits to embed the extended data packets yet I do not see 24-bit audio on the SDI output. I only ever get 20-bit audio.

 

Any suggestions?

0 Kudos
11 Replies
CheePin_C_Intel
Employee
69 Views

Hi,

 

Regarding the observation group 1 is required to be enabled so that other group can work, for your information, this is a known issue with the SDI Audio Embed IP. As a workaround, you would need to enable the group 1 first. Sorry for the inconvenience.

LBrad5
Beginner
69 Views

Is this something that will be fixed?

CheePin_C_Intel
Employee
69 Views

Regarding the 20 bit audio observation, would you mind to further elaborate on the observation? Probably some simulation in Modelsim will be helpful for further understanding. Thank you.

CheePin_C_Intel
Employee
69 Views

Hi,

 

By the way, just would like to check with you which Quartus version are you observing this issue? As I check in the KDB database, this issue seems to be observed previously in Q17.0. I understand that Engineering will be fixing it in the future Quartus release. 

 

As I understand it, the SDI Audio IP for Quartus 19.2 has been recently released. Would you mind to try with the 19.2 audio IP to see if similar issue still persist?

 

Please let me know if there is any concern. Thank you.

 

Best regards,

Chee Pin

LBrad5
Beginner
69 Views

I am using Quartus 18.1 and a Cyclone V device, so I am unable to try with 19.2.

CheePin_C_Intel
Employee
69 Views

Hi,

 

Thanks for your update. I understand that you are using Qstd and CV devices. Thus, you are unable to upgrade to Q19.2Pro. As a workaround, you might need to always enable the Group 1 currently. Sorry for the inconvenience.

 

Best regards,

Chee Pin

LBrad5
Beginner
69 Views

Hi,

 

I've just noticed that Quartus V19 has been released, but along with that they have removed support for SDI IP for Cyclone V. Can I use SDI II IP with the SDI audio IP? What are my options?

 

Thanks,

Luke

CheePin_C_Intel
Employee
69 Views

Hi,

 

Sorry for the delay. Regarding your latest inquiries, yes, you can use the SDI II IP with the SDI audio IP.

 

Thank you.

LBrad5
Beginner
69 Views

I've been told we cannot use SDI II IP + Audio IP + Cyclone V. Is this true?

CheePin_C_Intel
Employee
69 Views

Hi,

 

Sorry as I am not aware of the specific restriction. For your information, I have recently tested running SDI II IP with Audio IP in Q17.0Std and things seems to be working as expected.

 

Probably you can help to refer me to the specific link which is related to the restriction that you mentioned so that I could further follow up from there. Thank you.

CheePin_C_Intel
Employee
69 Views

Hi,

 

Just would like to follow up with you on this. Please let me know if there is any concern. Thank you.

 

 

Best regards,

Chee Pin

 

Reply