FPGA Intellectual Property
PCI Express*, Networking and Connectivity, Memory Interfaces, DSP IP, and Video IP
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
5917 Discussions

Max 10 - altera soft lvds (TX) vs Cyclone V - altlvds (RX) compatibility (CameraLink)

Altera_Forum
Honored Contributor II
1,003 Views

I'm trying to build CameraLink connection from MAX 10 using altera_soft_lvds (TX) IP core to Cyclone V using altlvds_rx. I figured out that there is one difference between both IP core generators. In altera_soft_lvds I've chosen inclock to data phase and in altlvds_rx there is data to clock phase (I assume it will be 360 deg - <phase in MAX 10>). 

In my case it will be 90 deg in MAX 10 and 270 deg in Cyclone IP core. The other settings are set the same in both cases. 

 

With this configuration my CameraLink connection does not work properly. I've changed the data-to-clock phase in altlvds_rx in Cyclone experimentally, and the connection works with that phase set to <285,300,315> deg. But each of these settings couse interferences in signal (the output image is full of glitches, 285 deg is the best but not perfect). 

 

When I connect max10 CameraLink output in this configuration to framegrabber it works fine so I assume there is problem with altlvds_rx. 

 

Also when I created CameraLink connection between MAX 10 altera_soft_lvds (TX) and MAX 10 altera_soft_lvds (RX) it works perfect. 

 

Does anybody have this problem and know the solution? 

 

PS. If needed I can do screenshots of both IP core generator settings in my project
0 Replies
Reply