FPGA Intellectual Property
PCI Express*, Networking and Connectivity, Memory Interfaces, DSP IP, and Video IP
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
5987 Discussions

STX V PCIE Configuration Issue

Altera_Forum
Honored Contributor II
816 Views

Hi, 

 

I am facing a problem while trying configuration write (type1) using gen3 rootport. I simply generated the rootport and endpoint (both gen3 stx V) from megawizard and connected them. After link up I tried a configuration write type0 and get a corresponding completion without data. Then I tried configuration write type1 but this time I didn't get the completion. I have checked the qword alignments as I already been using old gen2 rootport and endpoint for my simulations. 

 

Also In their generated example, they didn't tried configuration write type1 so I am in doubt whether this new rootport support type1 configuration or not 

 

Any related info will be highly appreciated 

 

Thanks 

Ali Umair
0 Kudos
0 Replies
Reply