FPGA Intellectual Property
PCI Express*, Networking and Connectivity, Memory Interfaces, DSP IP, and Video IP
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
5952 Discussions

Stratix v PCI Express Hard IP not detected

Altera_Forum
Honored Contributor II
968 Views

Hi , 

 

I'm using the example design for Stratix V Hard IP for PCI Express geenerated by Quartus prime 15.1 . 

My pc which uses Intel core i7-3770 is unble to detect it ,aother pc with Intel core i7 3615 QE is able to detect it. 

Tried a warm boot as well but no good. 

 

There is a similar thread with this poblem but with Quartus II 12.1 . 

 

Any idea what the Problem could be. 

 

Regards, 

Kaushik
0 Kudos
2 Replies
Altera_Forum
Honored Contributor II
119 Views

Hi, 

 

I m having the same problem with Intel i7-3770. The PCIe fails to enumerate .  

 

I really new to Altera so any suggestion would be really helpful.  

 

Thanks, 

spree
Altera_Forum
Honored Contributor II
119 Views

What lane rate have you set in the PCIe core? How are you connecting it to the motherboard? (riser cable?) 

 

The core has issues with lane rate negotiation in situations where it has to fall back to a lower speed. For example, when the device is compiled for Gen 2 and is plugged in to a motherboard which supports gen 2, but using say a riser cable which is not of high enough quality, it can cause both ends of the link to try the higher rate, fail because of the riser, but then the FPGA core locks up and fails to fall back to the lower speed and hence not enumerate.
Reply