Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
852 Views

problem using NetLogic AEL2005 in SGMII pass-through mode

Hi, 

 

I am using Altera TSE IP Core with fifoless, 1000BASE-X and use GXB transceiver configuration. I am using Stratix-IV development kit.  

 

In my design, I am sending data to an SFP module with optical fiber connected and then receive the data and compare whether I am getting back the same data as transmitted. 

 

I tried the design with SFP HSMC daughter card and it is working.  

 

Now I am using NetLogic AEL2005 chip in SGMII-pass-through mode to achieve the same purpose, i.e., sending out the data from GXB transmitter, going through the AEL2005 chip to the SFP module and then receiving the data coming from the SFP module through the AEL2005 to GXB receiver. But now I am not getting back the same data I transmitted, also the TSE MAC shows CRC-ERROR flag and DATA_LENGTH_INVALID flag,  

 

Is there somebody else who faced same type of trouble before? What could be the issue? 

 

 

Thanks 

sawaak
0 Kudos
6 Replies
Altera_Forum
Honored Contributor I
65 Views

problem solved...

Altera_Forum
Honored Contributor I
65 Views

Hi sawaak, 

 

i also have a problem with this PHY (AEL2005). 

i used to work with this PHY connected to SFP+ (10G traffic) and i got a list of registers from NetLogic that made it work ok. 

now i am trying to work with this NetLogic AEL2005 in SGMII pass-through mode but i get no link. 

by the way - i am also using the TSE IP Core, 1000BASE-X and use GXB transceiver configuration. 

do you know how to configure the AEL2005 PHY and the TSE MAC? 

 

thanks. 

Oren.
Altera_Forum
Honored Contributor I
65 Views

Hi Oren, 

 

You just need to configure registers 1.C01F and 1.C220 of AEL2005 as per your requirements, let me know if you still find trouble... 

 

thanks 

sawaak
Altera_Forum
Honored Contributor I
65 Views

thanks, 

i did configured the PHY - as i understand this configuration makes the PHY behave as a simple pass-through so what i am missing is the TSE configurations and indication for a link. 

i have configured the TSE as in the TSE MegaCore Function User Guide (5-24) but i don't know in which register i should check for the link. 

can you help me with this one?
Altera_Forum
Honored Contributor I
65 Views

I just configured the following registers of TSE 

 

1) Command Config Register 

2) PCS Device Ability Register 

3) PCS IF Mode Register 

4) PCS Control Register 

 

For link detection, you can use led_link signal. 

 

thanks 

sawaak
Altera_Forum
Honored Contributor I
65 Views

Hi Oren, 

 

I want to configure phy AEL2005 in XGMII mode for connecting to SFP+ (10G Traffic). 

and have to configure list of registers from NetLogic. What registers i have to configure? 

Please help me. 

 

Thanks  

latif_kcp
Reply