Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Valued Contributor III
968 Views

simulate DFIFO by using modelsim, outptout ports are zzzz

I use moselsim SE 10.1a to simulate DFIFO. Quartus ii software version is 12.0. DFIFO has six input ports and three outputs. I give DFIFO six input signals, including aclr, inputdata, rdclk, wrclk, rdreq and wrreq. All they can display correctly in modelsim. But three output ports are zzz,including rdempty, wrfull and output q. The color of three output ports is blue. 

rst is aclr; clk_48M is wrclk;clk_FFT is rdclk; filt_lp_data_i is inputdata;fft_real_in is output data port.  

I give the simulation results in attachments column. 

I have used DFIFO before but I didn't meet this problem. It frustrates me a lot. 

I hope someone who can help me.
0 Kudos
4 Replies
Highlighted
Valued Contributor III
16 Views

your wr clk is dead.

0 Kudos
Highlighted
Valued Contributor III
16 Views

I think I was looking at your rst and thought it was wr clock. is your reset active low or high. Did simulation manage to find fifo model?

0 Kudos
Highlighted
Valued Contributor III
16 Views

My reset is active low in my system. I know that aclr of DFIFO is active high. So in my code, aclr=~rst. 

How to know that simulation manages to find fifo model? The module ,including FIFO, has been successfully loaded in modelsim. Does it mean that simulation manages to find fifo model?
0 Kudos
Highlighted
Valued Contributor III
16 Views

If a component model is not found by modelsim it still compiles but when you run simulation it will issue a warning saying fifo is not bound.

0 Kudos