FPGA, SoC, And CPLD Boards And Kits
FPGA Evaluation and Development Kits
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
5283 Discussions

AND & OR, NAND & NOR, XOR & XNOR work inversely in MAX 10 Development kit

Altera_Forum
Honored Contributor II
1,315 Views

Hello geniuses, 

 

I am (new) working on MAX 10 Development Kit (10M50DAF484C6GES) using Quartus Prime 17.0 Lite Edition. My and & or program written in verilog in quartus software simulates functionality perfectly but on development kit works invesely (likely nand & nor, xor & xnor). I have kept default setting both in max10 and quartus ii software. I failed to find out the problem. please help me if anybody have any solution or idea what can be the issue of the problem. 

 

Thanks in advance..
0 Kudos
3 Replies
Altera_Forum
Honored Contributor II
178 Views

How do you know it works inversely on the development board? 

 

If this is your board: https://www.arrow.com/en/reference-designs/deca-development-kit-based-on-the-10m50daf484c6ges-max-10... 

 

the LEDs are ACTIVE LOW, so they will be ON when the output is LOW, and OFF when the output is HIGH. Is this what you believe is the 'inversely'?
Altera_Forum
Honored Contributor II
178 Views

Post some code.

Altera_Forum
Honored Contributor II
178 Views

Thanks a lot. You are absolutely right. I have understood the fact. The LEDs are ACTIVE LOW and PUSH BUTTON push create low pulse. Thinking every thing high, I commented they work inversely as I worked on xilinx spartan-6 which is active high. 

 

Thanks to help me my confusion.
Reply