FPGA, SoC, And CPLD Boards And Kits
FPGA Evaluation and Development Kits
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.

Advanced Boot Copier -

Altera_Forum
Honored Contributor II
868 Views

Hi, 

 

Advnaced Boot Copier for CFI Flash memory loads and jumps to a simple application (Hello World code). But it fails to run a "larger" application. The boot copier successfully validates the application using "CRC32". It loads and copys "successfully" into RAM. But somehow the application fails to run. Anyone has any ideas that what might go wrong? Please give me some hints/helps. 

 

Thank you, 

OnePlusOne
0 Kudos
3 Replies
Altera_Forum
Honored Contributor II
136 Views

Hi OnePlusOne - having similar issues here - did you get anywhere in your debug? 

C
Altera_Forum
Honored Contributor II
136 Views

 

--- Quote Start ---  

Hi OnePlusOne - having similar issues here - did you get anywhere in your debug? 

--- Quote End ---  

 

 

I passed that. But I could not recall what exactly was the fix. It has been for a while and I am not using that boot loader for now. I believe there is something to do with the interrupts.
Altera_Forum
Honored Contributor II
136 Views

Yeah thats what I think I'm seeing... seems like when the bootloader writes the new image over it's interrupt table the whole deal goes out to lunch even tho there is a alt_irq_disable_all (); thrown in...

Reply