FPGA, SoC, And CPLD Boards And Kits
FPGA Evaluation and Development Kits
Announcements
All support for Intel NUC 7 - 13 systems has transitioned to ASUS. Read latest update.
5844 Discussions

Agilex Board Test System difficulties

WWood7
Beginner
1,297 Views

I am BTS difficulties with our new DK-SI-AGI027FB Agilex I series Signal Integrity ES Development Kit with the AGIB027R31B1E1VAA SoC.

 

I tried getting BTS to work, and nothing would load. It said "Failed to read production information from this SOF in the FPGA." However, I tried loading bts_config.sof using Quartus Programmer. That seemed to work. I could then start the BTS and run the GPIO design.

 

However, I still could not run the design I wanted, qsfpdd800.  I could load its SOF with Quartus Programmer but I couldn't get the BTS GUI to start. So I tried restoring the Max10 using the POF in the "factory_recovery" directory using Programmer. It configured successfully but now the BTS won't run at all. It says "Failed to register GUI application" every time I try to start it. I've evidently made my problem worse.

 

Can anyone help? Thank you!

0 Kudos
1 Solution
Fakhrul
Employee
1,054 Views

Hi WWood7,


Sorry for the delay in response. I was trying to do some research internally regarding this issue. Here are some steps you can give a try first and see if it works:


1.    Could Download the BTS installation files from our website : https://www.intel.com/content/www/us/en/products/details/fpga/development-kits/agilex/i-series-transceiver/si-agi027.html

 select ES2 (if you are using an ES2 version of the board). Once downloaded please try to update with the following .pof

\examples\max10_system\max10_system\output_files\max10_system.pof


2.      Please restart computer and power cycle the dev kit before you configure.

Let’s see if these works, I will try to come out with another debugging step soon.


Regards,

Fakhrul


View solution in original post

11 Replies
Fakhrul
Employee
1,257 Views

Hi WWood7,


First, I'd like to know more about the issue and your application to have a better understanding and narrow it down to possible causes. If you can answer the following questions I'll appreciate it.


Can you try a simple design with POF/SOF? just to find out if problem is POF dependent.

May I know if this is a singular case or are you seeing the same issue in other new devices?


Regards,

Fakhrul


0 Kudos
WWood7
Beginner
1,248 Views

Hello Fakhrul,

Thank you very much for your reply. I think the problem is with the BTS executable, because I can load BTS SOFs using Programmer without errors. For example, I can load qsfpdd800.sof with Programmer. I just can't start BTS to use it. An error message box says "Failed to register GUI application" and BTS immediately quits. I cannot start the BTS clock controller either. 

I will attach the error message from the java console to this message next week when I am back in the lab.

Thanks again!

 

0 Kudos
WWood7
Beginner
1,243 Views
0 Kudos
WWood7
Beginner
1,191 Views

I am attaching the log file for today's attempt to start BTS. Also a screenshot of the error message.

Thank you,

WWood7

0 Kudos
WWood7
Beginner
1,163 Views

Also, in case it is relevant, I seem to have an an occasionally intermittent JTAG connection. When I run Programmer (22.3.0 build 104) I sometimes get the following error message when I try to load an SOF: 

Error(209053): Unexpected error in JTAG server -- error code 2.

Similarly, "jtagconfig" sometimes returns "JTAG chain broken" at the command line.

In both cases, just running the command again is enough to load the SOF. The connection seems OK but can be a little flaky. Replacing the USB cable with a new one didn't help.

I cannot find any documentation on Error 209053.

0 Kudos
Fakhrul
Employee
1,153 Views

Hi WWood7,


This issue is somehow related to this KDB: Why is the Board Test System (BTS) GUI unable to locate the USB-Blaster?.

Could you check whether you're using the same version of Quartus and BTS?


As for the JTAG issue, kindly refer to the following KDB as it maybe applicable to your current issue:

Error (209053): Unexpected error in JTAG server --error code 44

Error (209053): Unexpected error in JTAG server -- error code 126


Hope this would works!


Regards,

Fakhrul


0 Kudos
WWood7
Beginner
1,131 Views

Hello Fakhrul,

Thank you for the links. Unfortunately, they didn't help. Regarding the first link, I am using the same BTS and Quartus versions. Since my last post, I've upgraded from Quartus and BTS 22.3 to 22.4, since the latter BTS just recently appeared on the Intel website. I was hoping this might help, but it hasn't. I get the same errors. But again, I am using the same version of both.

The other two links you sent are not related to "error code 2" and are very old. I don't know what to think about them. They don't seem relevant.

I suspect the problem is JTAG related. I don't know if it means anything, but when I run the Programmer JTAG debugger, I get a message that says: "Warning: Uncertain JTAG chain." Is there anything relevant there? The JTAG debugger does show the correct components. The Quartus manual doesn't help much. (See attached picture.) 

Thanks again for your help.

0 Kudos
WWood7
Beginner
1,063 Views

Hi Fakhrul,

I am in need of a solution, or a replacement board. Could you let me know what my options for paid support are? Perhaps you could e-mail me with that information?

Thanks

0 Kudos
Fakhrul
Employee
1,055 Views

Hi WWood7,


Sorry for the delay in response. I was trying to do some research internally regarding this issue. Here are some steps you can give a try first and see if it works:


1.    Could Download the BTS installation files from our website : https://www.intel.com/content/www/us/en/products/details/fpga/development-kits/agilex/i-series-transceiver/si-agi027.html

 select ES2 (if you are using an ES2 version of the board). Once downloaded please try to update with the following .pof

\examples\max10_system\max10_system\output_files\max10_system.pof


2.      Please restart computer and power cycle the dev kit before you configure.

Let’s see if these works, I will try to come out with another debugging step soon.


Regards,

Fakhrul


WWood7
Beginner
1,029 Views

Dear Fakhrul,

Thank you very much for your quick reply. The BTS files you mention are the ones I am using. But I was using the max10_system.pof in the "system_restore" folder (or whatever it's called, I forget exactly). When I used the one you mentioned, the BTS works! Even the QSFPDD800 program is running now. Thank you for helping me get this started!

One question ... I guess I have an ES2 version of the board, since the program is working, but how do I know for sure? My FPGA is AGIB027R31B1E1VAA and the board serial number is AGI87TS0001137.

Many thanks again,

WWood7

0 Kudos
Fakhrul
Employee
1,007 Views

Hi WWood7,


I’m glad that your question has been addressed, I now transition this thread to community support. Regarding ES version, the ES and ES2 are engineering sample and they have some differences. For the exact difference, we need to check the functional description of the devices. One thing we can see is the schematic or user guide attached in the board website.


If you have a new question, feel free to open a new thread to get support from Intel experts. Otherwise, the community users will continue to help you on this thread. Thank you.





0 Kudos
Reply