FPGA, SoC, And CPLD Boards And Kits
FPGA Evaluation and Development Kits
Announcements
All support for Intel NUC 7 - 13 systems has transitioned to ASUS. Read latest update.
5853 Discussions

Agilex_HPS device not showing up in JTAG chain

cbhowmik
Employee
676 Views

jtagconfig returns:

0341A0DD AGFB014(F25A|R24AR0)

031830DD 10M16S(A|C|L)

Why don't I see the Agilex HPS device in the JTAG chain? 

0 Kudos
1 Solution
cbhowmik
Employee
614 Views

Thank you! I did have the switches in that order. The problem may have been that the previous step of configuring the FPGA with the SOF bitstream did not successfully complete (I was using an Enpirion board GHRD SOF instead of the Linear GHRD SOF. I have a Linear dev board).  And I am told that the HPS does not show up until the FPGA has been configured correctly. I was able to boot Linux in the HPS. Thank you for your help!

View solution in original post

0 Kudos
5 Replies
JohnT_Intel
Employee
651 Views

Hi,


May I know if you are using Intel development kit? If yes, may I know which board are you using?


0 Kudos
cbhowmik
Employee
641 Views

Hi, I am using the Agilex F-Series Transceiver SoC Development Kit, Rev A I believe. 

Thanks!

0 Kudos
JohnT_Intel
Employee
629 Views

Hi,


Could you check the SW3 switch on your board? You may refer to Table 9 of https://www.intel.com/content/www/us/en/programmable/documentation/ybp1566605314340.html to understand what is the setting used.


0 Kudos
cbhowmik
Employee
615 Views

Thank you! I did have the switches in that order. The problem may have been that the previous step of configuring the FPGA with the SOF bitstream did not successfully complete (I was using an Enpirion board GHRD SOF instead of the Linear GHRD SOF. I have a Linear dev board).  And I am told that the HPS does not show up until the FPGA has been configured correctly. I was able to boot Linux in the HPS. Thank you for your help!

0 Kudos
JohnT_Intel
Employee
610 Views

Glad to hear the issue is resolved.


0 Kudos
Reply