Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Novice
1,171 Views

Altera USB Blaster on Windows 10 code 39 error

I have a Terasic DE0-Nano Cyclone IV with built-in USB Blaster.

I am using:

OS: Windows 10 Pro

Version: 1809

Build: 17763.316

 

I have tried to USB Blaster driver from Quartus II 9.1, 13.0, 13.1, 18.0, and 18.1.

I have tried disabling driver signing, but, this is probably useless since I never got an error message about an unsigned driver.

 

The Altera USB Blaster driver installs without issue, but, I get caution sign by the device in device manager and the error below. Needless to say the device is not recognized by any version of Quartus II mentioned above or the Terasic Control Panel.

 

I have scrounged the forums, but, I am not finding a solution. Does anyone know how to fix the driver or if there is an alternate driver? This is my first FPGA, I would love to work through some tutorials, but, can't get past the driver issue.

 

Error Text:

Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)

 

{Bad Image}

%hs is either not designed to run on Windows or it contains an error. Try installing the program again using the original installation media or contact your system administrator or the software vendor for support. Error status 0x

0 Kudos
5 Replies
Highlighted
Employee
205 Views

Hi Stephen, Could you please update the USB-Blaster drivers? Refer the "Installing the USB Download Cable Driver on Windows" from the below link & video too. https://www.intel.com/content/www/us/en/programmable/documentation/nfa1418282998564.html https://www.youtube.com/watch?v=QGcikqzV064 Please let me know if you have different concern. Regards, Vikas
0 Kudos
Highlighted
Novice
205 Views

Hi Vicky,

 

The problem I described in the original post is after updating the driver as described in the link below. Sorry I wasn't more clear about that.

 

https://www.intel.com/content/www/us/en/programmable/documentation/nfa1418282998564.html?language=en...

 

Thanks,

-Steve

 

0 Kudos
Highlighted
Employee
205 Views

Hi Steve, Please go through the following links & try at your end since I can`t replicate the issue. Refer " Code 39 “Windows cannot load the device driver for this hardware... (Code 39).”' https://support.microsoft.com/en-us/help/310123/error-codes-in-device-manager-in-windows https://forums.intel.com/s/question/0D70P000005tBAdSAM/couldnt-install-usb-blaster-driver-on-hp-dv41... I am also looking for appropriate solution. Thanks & Regards, Vikas
0 Kudos
Highlighted
Novice
205 Views

Hi Vikas,

 

Thank you for this additional troubleshooting information. Neither of these links fix the problem I am experiencing. That said, I was able to connect the DE0-Nano Cyclone IV on another computer (Mac Mini ~2013) with the same Windows version and build. The instructions you provided work flawlessly on the Mac Mini. The computer that does not work is a Microsoft Surface Book 2. I recently noted that an older USB 2.0 hub I have also does not work on the Surface Book. I think the problem I am experiencing is due to some USB compatibility problem with the Surface Book 2. Regardless, I have a working solution for the DE0-Nano so I am good to go.

 

Thanks again for you assistance.

 

-Steve

 

 

 

Highlighted
Beginner
205 Views

I'm having the same issue on the same windows build except I'm using a Dell OptiPlex desktop PC. On another Dell PC with Windows 10 the usb-blaster installed correctly. I also get the same issue on a Dell laptop.

0 Kudos