FPGA, SoC, And CPLD Boards And Kits
FPGA Evaluation and Development Kits
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
5157 Discussions

Arria® 10 GX FPGA Development Kit, Factory Reset

jdun
Novice
248 Views

I am trying to do program the flash via Quartus, and it fails. So I even tried doing a factory  reset using the BTS GUI, and it fails.  I can program .sof files but not a factory reset or program the flash.

I looked at the bts_log and it erases the flash chip , but once it starts programming the memory it fails. Same thing is Quartus I can erase or read the flash, but fails when writing it.

Do I have a bad memory chip?

I believe I have the PRD version.

All the switches are in the default settings

Any Ideas?

0 Kudos
6 Replies
YuanLi_S_Intel
Employee
230 Views

Hi Jdun,


May i know which programming file you are using to program the flash? Is it JIC / POF? Also what are the programming scheme you used in the design?


Regards,

Bruce


jdun
Novice
222 Views

Well First I want to rest the board back to factory settings, to make sure it is still working. I am first trying to use the bts-gui. I use it to load the factory reset, but it fails. I looked at the log and it erases the flash, but once it goes to write the flash it fails.

the MSEL switches are in the default setting or MSEL 0 switch = off,  MSEL1 and 2 switch = on. But I wouldn't the MSEL would even matter when loading the Flash.

Is there a Flash protection bit? Or write protection? How do I turn that on or off?

It appears in the schematic this bit is pulled-up high, so I don't think  that is the problem.

After I can load the Factory I plan on using a pof, or whatever will work to program the FPGA.

YuanLi_S_Intel
Employee
213 Views

MSEL setting is important in determining which programming file to load. Your existing MSEL setting is meant for passive serial / fast passive parallel configuration scheme.


Can you try to change your MSEL to OFF OFF ON? Then try to load the JIC file again?


jdun
Novice
202 Views

It appears something is wrong with the board, the computer  now can't even detect the hardware. I tried different MSEL settings. I tried on board and off board usb blasters. I am not sure what is wrong.

The onboard USB Blaster is not detected, and using an offboard USB Blaster(J17) the autoscan fails.

I tried the other Jtag port for the Max2 (J23) and it detects the Max2.

Before I was able to program .sof and now nothing. I tried switching pins on SW4 to enable and disable JTAG, and both settings don't work. 

I was wearing anti static wrist band.

YuanLi_S_Intel
Employee
192 Views

Can you try to change all the switches to default position and try to detect the USB Blaster? If still cant be detected with both on board and off board Blaster, i think the board might have problem already.


jdun
Novice
155 Views

After looking at the schematic, the onboard and offboard USB Blaster go through the Max2. Do you have the code for the Max2? I can find the code for the Max 5 but not the Max2. Maybe The code got corrupted.

Reply