Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
749 Views

Arria V DevKit BTS not running (despite path adjust)

Dear all 

I'm currently not able to start up the BTS in my Arria V DevKit. I followed the instructions in 

http://www.altera.com/support/kdb/solutions/rd01292013_416.html 

to get my paths ready, but it didn't help me out so far.  

The "jtagconfig --version" command results in 

Version 13.0.1 Build 232 06/12/2013 Service Pack 1 SJ Full Version 

Copyright (C) 1991-2013 Altera Corporation 

Quartus II resides in 

C:\altera\13.0sp1\quartus\bin64 

The BTS in: 

C:\altera\13.0sp1\kits\arriaVGX_5agxfb3hf35_start\examples\board_test_system 

BTS version: Arria V GX Starter Kit v12.1.1.1 

I still get the message that required Quartus II was not found. 

What else needs to be done? 

Regards, Peter
0 Kudos
2 Replies
Altera_Forum
Honored Contributor I
53 Views

Further trying showed that the BTS will come up with my 12.1sp1 web edition (but of course is no finding the Arria V device, because it's not part of the web edition).  

 

The hints read "BTS needs 12.1sp1 or later". Why does it not work with 13.0sp1? Is there need to download exactly 12.1sp1 subscription edition? (with a fat red writing about constraint file reordering and an incompatibility of the noted patch with Arria V devices...) 

 

...what to do in this case?
Altera_Forum
Honored Contributor I
53 Views

Hi majestix, 

 

I think the BTS for Arria V Kit is the craziest one ! 

 

If you do each of the following steps, you may have a chance to fix the problem : 

 

(0. Install QuartusII v 12.1sp1) 

 

1. Set all the Environment variables according to the 12.1sp1 version 

 

_ PATH 

_ QUARTUS_ROOT 

_ QUARTUS_SH 

_ SOPC_KIT_NIOS2 

(maybe some of them are useless, set them anyway) 

 

2. Restart your computer to be sure (and check back the variables once again) 

 

3. Switch on your boad and open Quartus 12.1sp1, then open Programmer 

 

4. Program the FPGA with file : 

\altera\12.1sp1\kits\arriaVGX_5agxfb3hf35_start\examples\board_test_system\sof\bts_config.sof 

 

5. Once FPGA is programmed successfully, launch Nios Shell, version 12.1sp1 : 

\12.1sp1\nios2eds\Nios II Command Shell.bat 

 

6. Navigate to the bts.jar folder : 

\altera\12.1sp1\kits\arriaVGX_5agxfb3hf35_start\examples\board_test_system 

 

7. Launch BTS from the command line : 

java -jar BTS.jar 

 

8. Enjoy the wonderful BTS GUI ! :) 

 

I did all those steps for the fisrt time. It worked ! 

Maybe for the second time, you can use shorcuts, 

Hope it will help you, 

 

AC.
Reply