FPGA, SoC, And CPLD Boards And Kits
FPGA Evaluation and Development Kits
5915 Discussions

BeMicro SDK - trying to run the tutorial

Altera_Forum
Honored Contributor II
1,171 Views

Hi, 

I am a software developer and I'm investigating the potential of using NIOS II with MicroC/OS-II for my application. I am able to execute the tutorial until I get to 4.2 when I get the  

system id mismatch - connected: "0x6060d7d5", expected: "0x0".  

Hitting the (REFRESH CONNECTIONS) button does not correct the issue. 

 

The System ID Properties is included below: 

expected system id base address: 0x80002a8 

expected system id: 0x0 

connected system id: 0x6060d7d5 

expected system time stamp: 1313716022 

connected system time stamp: 1287701530 

 

I'm running Quartus 11.1 with NIOS II EDS from the Altera website. 

 

Any help here would be appreciated. 

Thanks! 

John
0 Kudos
4 Replies
Altera_Forum
Honored Contributor II
291 Views

I am having the same problem. Can anybody comment?

0 Kudos
Altera_Forum
Honored Contributor II
291 Views

I think it has something to do with the EPCS chip. Any thoughts?

0 Kudos
Altera_Forum
Honored Contributor II
291 Views

I've the same problem. 

Does this simply mean that the nios system in our fpga is different from the one used in the lab material? Can flashing the image from the lab material solve the issue? This is my first hands on fpga, must investigate before doing things
0 Kudos
Altera_Forum
Honored Contributor II
291 Views

It works! 

Just follow Appendix A instructions to restore the factory image of the lab materials: 

 

In the Nios2 Command shell, go to the Factory_Image directory and type 

source restore_factory_image.sh
0 Kudos
Reply