FPGA, SoC, And CPLD Boards And Kits
FPGA Evaluation and Development Kits
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.

Bitec

Altera_Forum
Honored Contributor I
995 Views

Hi ; 

 

Does anyone try the referece designs in the bitec website ? I woulf like to know if these examples are really working. 

 

thank you
0 Kudos
9 Replies
Altera_Forum
Honored Contributor I
165 Views

I'm looking to execute the pass through using HSMC Bitec DVI card. I put in my design the clocked video input connected to the clocked video output , but I didn't have any result.  

Please can someone help me in this problem. 

 

Rabia
Altera_Forum
Honored Contributor I
165 Views

HI, 

 

I have the same problem.NOne of the designs are working with bitec.I have reference design from the bitec website. 

I am using the design DVI_1080P_Loop_through_C120_Beta 

 

but it has many problems.
Altera_Forum
Honored Contributor I
165 Views

i never got the Bitec DVI input port to work with their designs or my own

Altera_Forum
Honored Contributor I
165 Views

I'm not sure which ref desgin you guys are talking about, but... 

 

I used the HSMC to Displayport card. 

I tried the output side, but it was working fine. 

I've tried on the A2GX and S4GX as well. 

and both working fine with me.
Altera_Forum
Honored Contributor I
165 Views

Hi, 

 

I am trying the design with the design with Cyclone III ...The one with Arria and other are working.I have tried them too.But the cyclone 3 design has problem..
Altera_Forum
Honored Contributor I
165 Views

 

--- Quote Start ---  

I'm looking to execute the pass through using HSMC Bitec DVI card. I put in my design the clocked video input connected to the clocked video output , but I didn't have any result.  

Please can someone help me in this problem. 

 

Rabia 

--- Quote End ---  

 

 

 

I am trying the same thing as you..The cyclone 3 example has a stupid mistake which I discovered today.It doesnot have the constraints file added from to it for CVI and CVO... 

The path to add them is: 

add the altera .v files. 

C:\altera\10.0sp1\ip\altera\clocked_video_input\src_hdl 

 

and also the sdc constraints file which is in the link  

 

C:\altera\10.0sp1\ip\altera\clocked_video_input 

 

Add for both CVI and CVO.. 

 

For more reference look the design  

 

http://www.bitec.ltd.uk/dvi_loopthrough_1080p_civ.pdf 

 

It is same deign but just with cyclone IV. 

Alteast the design synthesis successfully.U can add the files which are added in this design to the eg of cyclone 3 design and it works.. 

 

I prefer to create my own design, similar to the example but more logical.If it doesnot work I can upload it here in future. 

 

Hope it helps..
Altera_Forum
Honored Contributor I
165 Views

so you did get the CIII loopback design to work in hardware?

Altera_Forum
Honored Contributor I
165 Views

Hi, 

 

I got it compiled and synthesized and fitted n everything.I am going to try it in the Hardware this week or may b next.I will post it if I get it working (which I have to anyways and at any cost). 

 

 

Sn
Altera_Forum
Honored Contributor I
165 Views

Hi, 

 

I got the code working on the DVI board Cyclone 3.The pre compiled code J8.sof can be successfully downloaded but when if I compile and synthesize the code on my own I have some errors but the precompiled code from bitec is working fine. 

 

If anyone needs help let me know!! 

 

Sn
Reply