FPGA, SoC, And CPLD Boards And Kits
FPGA Evaluation and Development Kits
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
5283 Discussions

Can't SSH to Arria 10 Dev Board

Altera_Forum
Honored Contributor II
969 Views

I just received our Arria 10 Dev Boards and I'm running through the quick start guide. I can get to the web interface and blink some lights and change the LCD message. I tried to SSH to it and the following happened: 

 

$ ssh root@192.168.0.21The authenticity of host '192.168.0.21 (192.168.0.21)' can't be established. 

ECDSA key fingerprint is SHA256:6Roa+AUDD3RyzVleUJS04lWWt7tdVvD1LrZBkHTwADE. 

Are you sure you want to continue connecting (yes/no)? y 

Please type 'yes' or 'no': yes 

Warning: Permanently added '192.168.0.21' (ECDSA) to the list of known hosts. 

Connection to 192.168.0.21 closed by remote host. 

Connection to 192.168.0.21 closed. 

 

All subsequent attempts end the same: 

 

$ ssh root@192.168.0.21 

Connection to 192.168.0.21 closed by remote host. 

Connection to 192.168.0.21 closed. 

 

Any idea what's happening?
0 Kudos
2 Replies
Altera_Forum
Honored Contributor II
203 Views

Try to add some -v's to get more verbose debug output: 

 

ssh -vvv -o StrictHostKeyChecking=no -o UserKnownHostsFile=/dev/null root@192.168.0.21  

You can also see if you get any response from the server using telnet or netcat: 

nc 192.168.0.21 22  

You should see something like: 

SSH-2.0-OpenSSH_7.5p1-hpn14v12 

 

depending upon the ssh version you hav running on your board.
PJais1
Novice
203 Views

Hello , i am facing same error.On entering the command :

 ssh -vvv -o StrictHostKeyChecking=no -o UserKnownHostsFile=/dev/null root@192.168.1.10

OpenSSH_6.6.1, OpenSSL 1.0.1f 6 Jan 2014

debug1: Reading configuration data /etc/ssh/ssh_config

debug1: /etc/ssh/ssh_config line 19: Applying options for *

debug2: ssh_connect: needpriv 0

debug1: Connecting to 192.168.1.10 [192.168.1.10] port 22.

debug1: Connection established.

debug3: Incorrect RSA1 identifier

debug3: Could not load "/home/bmit/.ssh/id_rsa" as a RSA1 public key

debug1: identity file /home/bmit/.ssh/id_rsa type 1

debug1: identity file /home/bmit/.ssh/id_rsa-cert type -1

debug3: Incorrect RSA1 identifier

debug3: Could not load "/home/bmit/.ssh/id_dsa" as a RSA1 public key

debug1: identity file /home/bmit/.ssh/id_dsa type 2

debug1: identity file /home/bmit/.ssh/id_dsa-cert type -1

debug3: Incorrect RSA1 identifier

debug3: Could not load "/home/bmit/.ssh/id_ecdsa" as a RSA1 public key

debug1: identity file /home/bmit/.ssh/id_ecdsa type 3

debug1: identity file /home/bmit/.ssh/id_ecdsa-cert type -1

debug1: identity file /home/bmit/.ssh/id_ed25519 type -1

debug1: identity file /home/bmit/.ssh/id_ed25519-cert type -1

debug1: Enabling compatibility mode for protocol 2.0

debug1: Local version string SSH-2.0-OpenSSH_6.6.1p1 Ubuntu-2ubuntu2.13

debug1: Remote protocol version 2.0, remote software version OpenSSH_7.8

debug1: match: OpenSSH_7.8 pat OpenSSH* compat 0x04000000

debug2: fd 3 setting O_NONBLOCK

debug3: load_hostkeys: loading entries for host "192.168.1.10" from file "/dev/null"

debug3: load_hostkeys: loaded 0 keys

debug1: SSH2_MSG_KEXINIT sent

and it hangs after this command.

 

Also by entering :  nc 192.168.1.10 22 , the terminal shows following output.

SSH-2.0-OpenSSH_7.8

 

Could you help with above query?

 

Thanks,

Priya

 

Reply