FPGA, SoC, And CPLD Boards And Kits
FPGA Evaluation and Development Kits
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
5158 Discussions

Configuration Error in Stratix 10 After programming .jic file

Vivek_tiwari
Beginner
827 Views

I Tried programming Stratix 10 FPGA kit with .jic file using jtag msel pins as MSEL[2:0] as 111 and it was programmed successfully configuration error led D3 was still glowing red after that i power cycle the board and changes MSEL for 011 (AS Normal) and also tried 001 (AS FAST) but that config error led always glowing RED and its not Configuring at all 
I want to program S10 through FLASH so even After power cycle i dont have to program again 

I dont have any problem to program .sof  then config_done led is glowing green

0 Kudos
15 Replies
JohnT_Intel
Employee
811 Views

Hi,


Could you try to change the MSEL for 011 (AS Normal) and try to programmed the jic file? May I know how do you convert the jic file if you are still facing issue?


Could you try to follow the guide in https://www.intel.com/content/dam/www/programmable/us/en/pdfs/literature/hb/stratix-10/ug-s10-config... Chapter 7.4.1 and see what is the configuration status after you power cycle the board?


Vivek_tiwari
Beginner
806 Views

Hi John,

 

I tried with MSEL for 011(AS Normal) and there is no change in result.

I am converting file through (Convert Programming Files) tool and tried (Programming File generator ) as well.

I am attaching some screenshots for your reference .

 

Thanks,

Vivek

JohnT_Intel
Employee
805 Views

Hi,


Could you manually probe nStatus and nConfig pin? The reason is that it seems like the configuration has not performed.


May I know if this is your own board or development kit?


Vivek_tiwari
Beginner
800 Views

Hi,

 

I don't know how and where can I probe/find these pins.

 

I am using the development kit.

JohnT_Intel
Employee
791 Views

Hi,


May I know which specific development kit are you using? Is it this board https://www.intel.com/content/www/us/en/programmable/products/boards_and_kits/dev-kits/altera/kit-s1...?


Vivek_tiwari
Beginner
782 Views

Yes this is exactly the one I am using

Vivek_tiwari
Beginner
780 Views

1SG280LU2F50E2VG this is the part number written on FPGA

JohnT_Intel
Employee
779 Views

Hi,


Could you provide me the SW1 DIP switch setting used? Have you try to set it to Fast AS mode (001)?


Have you try to program the sof file?


Vivek_tiwari
Beginner
776 Views

Hi,

 

I've tried both (001) AS FAST and (101) AS Normal as well.

 

I do not have any problem in programming .sof file 

 

I am facing issues for .jic file.

 

 

JohnT_Intel
Employee
765 Views

Hi,


Could you share with me your SOF and JIC file?



JohnT_Intel
Employee
743 Views

Hi,

 

Could you try to program using the attached jic generated in Quartus 21.1?

Vivek_tiwari
Beginner
666 Views

Hi,

Before I could download your JIC I flashed mine and looks like it got corrupted and board is getting heated and turning off after 5 mins.

Also not able to program anything  and getting this error while trying to program .sof "device has stopped receiving configuration data" 

If you know something about this please help.

Swapnil_29
Novice
657 Views

I work with @Vivek_tiwari .

 

Also some additional  data points- MAX_ERROR error led d3 glows for brief period of time say 1-2 mins and board is switching off.

 

@JohnT_Intel and other members- realty appreciate if we can get some pointers.

 

We are blocked and this Stratix10 GX Development kit is unusable for any program and development. Need critical inputs.

 

Thank you

 

Vivek_tiwari
Beginner
649 Views

Also We tried different power supply(Which is working wine for different S10 Board) but it's getting power off inside 10 mins MAX 

Reply