Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
1,101 Views

Control panel 2.1 cannot see DE1

I am using a DE1 with Quartus 13.1 and the Control Panel 2.0.1 on Windows 7 64 bit. When I first received the DE1 the control panel connected and barring a minor issue where I had to reboot the PC to be able to write the DE1 flash it all worked as expected. Quartus works perfectly and I don't have any of the issues that others have reported getting the programmer USB interface to work. 

I now need to modify the DE1 flash again and I cannot get the Control panel application to see the DE1 (it tells me to check the power and USB cable) 

I have tried the suggestion on the Altera site to manually program the control panel .sof and run the niosdownload.bat file. Both of these operations complete successfully but the control panel application still cannot connect. 

The VGA output displays the blended colour bars image after doing this.  

I have also tried the above steps, then rebooted the PC and run the control panel (just in case the programmer or batch file had not released the interface correctly) but the same failure occurs. 

 

Is there anything else I might have overlooked? Is there a more convenient tool for writing the flash? 

 

Thanks, 

Andy
0 Kudos
6 Replies
Altera_Forum
Honored Contributor I
63 Views

Hi Andy, 

 

Could you please provide the error message when the control panel (version 2.1 or 2.0.1 ?) is trying to establish connection to your DE1 board ?  

 

The VGA output displays the blended color bars image could be the result of  

1. the control panel is not connected or  

2. re-compilation under a different version of Quartus II without additional setting in .sdc file. 

 

David from Terasic
Altera_Forum
Honored Contributor I
63 Views

using control panel 2.0.1, I get the following message: 

Failed to find the FPGA board. Please make sure: 

1. The FPGA Board and PC are connected by an USB cable. 

 

2. The FPGA Board is power on. 

 

I checked that the FPGA is connected to the computer and that it is on. 

The USB blaster driver is installed and I'm able to program the board through Quartus 13.0sp1. 

 

Please help 

 

 

--- Quote Start ---  

Hi Andy, 

 

Could you please provide the error message when the control panel (version 2.1 or 2.0.1 ?) is trying to establish connection to your DE1 board ?  

 

The VGA output displays the blended color bars image could be the result of  

1. the control panel is not connected or  

2. re-compilation under a different version of Quartus II without additional setting in .sdc file. 

 

David from Terasic 

--- Quote End ---  

Altera_Forum
Honored Contributor I
63 Views

 

--- Quote Start ---  

using control panel 2.0.1, I get the following message: 

Failed to find the FPGA board. Please make sure: 

1. The FPGA Board and PC are connected by an USB cable. 

 

2. The FPGA Board is power on. 

 

I checked that the FPGA is connected to the computer and that it is on. 

The USB blaster driver is installed and I'm able to program the board through Quartus 13.0sp1. 

 

Please help 

--- Quote End ---  

 

 

Hi there, 

 

Are you also running DE1 control panel 2.0.1 in Windows 7 64-bit ? Have you tried the latest version 2.1 from our website de1.terasic.com

 

What's worth trying is you can program the FPGA manually and launch DE1 control panel to see if the connection is established successfully.  

 

David from Terasic
Altera_Forum
Honored Contributor I
63 Views

I have the same problem. Just wonder if anyone knows how to fix it. It shows exactly the same information: 

Failed to find the FPGA board. Please make sure: 

1. The FPGA Board and PC are connected by an USB cable. 

2. The FPGA Board is power on. 

 

Please help!
Altera_Forum
Honored Contributor I
63 Views

 

--- Quote Start ---  

I have the same problem. Just wonder if anyone knows how to fix it. It shows exactly the same information: 

Failed to find the FPGA board. Please make sure: 

1. The FPGA Board and PC are connected by an USB cable. 

2. The FPGA Board is power on. 

 

Please help! 

--- Quote End ---  

 

 

Hi there, 

 

What is your Quartus version and OS ? Would you be able to program the DE1 board from Quartus ? 

 

Davi from Terasic
Altera_Forum
Honored Contributor I
63 Views

Hi, 

 

Are you working with the Altera DE-1 Cyclone II kit or the Terasic DE-1 Cyclone V kit? Check if there are other USB ports on the kit. Since the kit uses built-in USB blaster, there would be another USB port for the Control panel / HPS to work with. Try connecting it to the other USB port and then check. If not, then power off the kit, connect the USB blaster cable to the kit ,then power it on again and try using the Control Panel.
Reply