Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
2,169 Views

Cyclone 10 GX PCIe dev kit?

Are there any Cyclone 10 GX PCIe dev kits available or will any such dev kits be available soon?

0 Kudos
16 Replies
Altera_Forum
Honored Contributor I
172 Views

Hi Petter, 

 

Cyclone 10 GX PCIe dev kit board is still under development. Tentative availability is around 2018 Jan time frame. 

 

Thanks. 

 

Best Regards, 

spdl2001 

(This message was posted on behalf of Intel Corporation)
MKama
Beginner
172 Views

Hallo,

We have brought a Intel Cyclone 10 GX development kits and want to know is this kits is working with PCIe or are three PCIe dev avaliable in this board?

 

Best regards

Kamal

Altera_Forum
Honored Contributor I
172 Views

I observe that the Cyclone 10 GX PCIe dev kit is available for purchase now. 

 

But unfortunately the 10 GX is only supported in the Quartus "pro" edition. 

 

I expected all members of the Cyclone 10 (new entry level family) to be supported by the "lite" edition :-( 

I'll probably get an Artix7 AC701 PCIe board instead as the 200kLE PCIe enabled device is supported in the free edition of Vivado.
Altera_Forum
Honored Contributor I
172 Views

Actually the pro edition can be used for free when building for Cyclone 10 GX devices.  

Which means that I'll probably will go for the GX, depending upon when it will be available. 

I see that buyaltera.com has an entry for the Cyclone 10 GX dev kit, but the quantity available is 0 at present.
Altera_Forum
Honored Contributor I
172 Views

Hello guys, 

Where is located the development Kit Package and Board test system file of the board Cyclone 10 GX? 

Is it available for download? 

 

Thanks.
Altera_Forum
Honored Contributor I
172 Views

Seems like they have only published the user guide and schematics so far: 

 

https://www.altera.com/products/boards_and_kits/dev-kits/altera/cyclone-10-gx-development-kit.html 

 

The user guide describes the development kit package which can be downloaded, so I would expect it to be available later.
Altera_Forum
Honored Contributor I
172 Views

Are there any news regarding this kit? I placed an order in December, but I haven't received any information regarding delivery date yet.

Altera_Forum
Honored Contributor I
172 Views

I just received this board. Is there any reference design is available for this board ( Cyclone 10 GX Development Kit ) ???

Altera_Forum
Honored Contributor I
172 Views

Glad to see that it's available even though I haven't received mine yet. 

 

There is a golden_top in the kit archive which can be found at the url given in my message above. But you might have received this with your kit already.
Altera_Forum
Honored Contributor I
172 Views

I just received my board. But running jtagconfig it seems like it does not properly detect the device: 

 

jtagconfig --version Version 17.1.0 Build 240 10/25/2017 SJ Pro Edition Copyright (C) 2017 Intel Corporation. All rights reserved.  

 

jtagconfig 1) CV SoCKit on zappa 02D020DD 5CSEBA6(.|ES)/5CSEMA6/.. 4BA00477 SOCVHPS 2) USB-Blaster on zappa 020F40DD 10CL040(Y|Z)/EP3C40/EP4CE30/.. 3) USB-BlasterII on zappa 031820DD 10M08SA(.|ES)/10M08SC 02E120DD ! Captured DR after reset = (0063041BB02E120DD) Captured IR after reset = (0AAD55) Captured Bypass after reset = (2) Captured Bypass chain = (2) JTAG clock speed 24 MHz  

 

It detects the other devices I have connected to the host "zappa".  

 

Also running BoardTestSystem.sh results in a Java related error: 

 

Error: Could not find or load main class com.intel.bts.BtsApp  

 

Did anybody have similar results with this board? It did not come with any software but I downloaded it from the link above in this thread.
Altera_Forum
Honored Contributor I
172 Views

Also trying to load a sof file using quartus_pgmw results in 

 

Error(209066): The instruction register length for the 10CX220YF780 device at position 2 in the JTAG chain is unknown
Altera_Forum
Honored Contributor I
172 Views

If the device is not recognized, you may have hardware issue. I received 3 of these Cyclone 10 GX development kit. I am using the same PC. 2 of them successfully work without any problem. Third one only recognize the flash device but not FPGA. I am returning the failed one.  

 

 

 

 

 

 

--- Quote Start ---  

I just received my board. But running jtagconfig it seems like it does not properly detect the device: 

 

jtagconfig --version Version 17.1.0 Build 240 10/25/2017 SJ Pro Edition Copyright (C) 2017 Intel Corporation. All rights reserved.  

 

jtagconfig 1) CV SoCKit on zappa 02D020DD 5CSEBA6(.|ES)/5CSEMA6/.. 4BA00477 SOCVHPS 2) USB-Blaster on zappa 020F40DD 10CL040(Y|Z)/EP3C40/EP4CE30/.. 3) USB-BlasterII on zappa 031820DD 10M08SA(.|ES)/10M08SC 02E120DD ! Captured DR after reset = (0063041BB02E120DD) Captured IR after reset = (0AAD55) Captured Bypass after reset = (2) Captured Bypass chain = (2) JTAG clock speed 24 MHz  

 

It detects the other devices I have connected to the host "zappa".  

 

Also running BoardTestSystem.sh results in a Java related error: 

 

Error: Could not find or load main class com.intel.bts.BtsApp  

 

Did anybody have similar results with this board? It did not come with any software but I downloaded it from the link above in this thread. 

--- Quote End ---  

Altera_Forum
Honored Contributor I
172 Views

Thank you for your reply. But it seems like it's able to detect the jtag id 02E120DD. Do you see the same id on your board when you run jtagconfig?

Altera_Forum
Honored Contributor I
172 Views

Fortunately it seemed to be a software problem. Seem to be that jtagd on my programming host "zappa" hasn't been restarted in a long time. So it never loaded the more recent pgm_parts.txt file. After re-starting jtagd it can identify the device: 

 

jtagconfig 1) CV SoCKit on zappa 02D020DD 5CSEBA6(.|ES)/5CSEMA6/.. 4BA00477 SOCVHPS 2) USB-Blaster on zappa 020F40DD EP3C40/EP4CE(30|40) 3) USB-BlasterII on zappa 031820DD 10M08SA(.|ES)/10M08SC 02E120DD 10CX220Y  

 

And programming using quartus_pgmw worked fine from one of my build hosts.
Altera_Forum
Honored Contributor I
172 Views

I managed to get java configured correctly so the BoardTestSystem.sh is up and running. But unfortunately it seem to assume that the board is connected to the local host (i.e. the one running the java application) and does not support jtag over the network like quartus_pgm, system_console, jtagconfig, etc 

 

Is there a way to enable remote access in the board tests system java app?
Altera_Forum
Honored Contributor I
172 Views

During my previous invocation I got an error: 

 

Caused by: java.lang.NullPointerException  

After re-starting the java app it probed the devices over the network and the statsus was "Board Connected. Then I managed to read the temps and the voltages using the app, but then it died again: 

 

 

Apr 29, 2018 11:30:53 AM com.altera.avalon_i2c.I2CCont readReg16 SEVERE: addr 0x5c, reg 0x5 java.lang.Exception: Write, NO ACK Shunt Voltage Register read error: 0xffff Bus Voltage Register read error: 0xffff  

 

Restarting it I can't seem to connect again: 

 

Apr 29, 2018 11:35:11 AM com.intel.bts.JtagInfo createDeviceInfoMapArray SEVERE: java.io.IOException: : get_service_paths device  

The java app seem to be a bit unstable.
Reply