Community
cancel
Showing results for 
Search instead for 
Did you mean: 
TRAN_HIEU_007
Beginner
157 Views

Cyclone 10GX with 2 port SFP 1G test.

I am designed a custom Broad with Cyclone 10GX and 1G SFP interface. I am using project test altera_eth_tse_native_phy_w_1588. I have been run TEST_PHYSERIAL_LOOPBACK and TEST_SMA_LB was succesfull in my Custom broad and Cyclone10GX deverlopment kit. But, when I was running TEST_1588 0 1 1G. Project could not transmitted frame succesfull.  Can you show me where the error is or give me a project test with sfp use TSE ipcoreCapture.PNGschematics.pngPin connect.png

 

0 Kudos
7 Replies
SengKok_L_Intel
Moderator
123 Views

Hi,


Is the problem only happen in your custom board, where there C10 GX development board is working fine?


Do both channels pass the TEST_SMA_LB test?


TRAN_HIEU_007
Beginner
114 Views

I have tested successfully with TEST_PHYSERIAL_LOOPBACK and TEST_SMA_LB in both broad (My custom broad and C10 GX development board). Moreover, I do not understand why when I disconnect SFP cable TEST_SMA_LB still successful. This is my project test in Quartus 18.0        https://drive.google.com/file/d/1F2bbFeMCh-TXbeFQpxwCKBGHeSaQj4gC/view?usp=sharing

Can you give true project test SFP 1G for Cyclone10GX. I need ping from my computer to custom broad over SFP module and TSE IP.

TRAN_HIEU_007
Beginner
110 Views

Hi SengKok! My team has build a project ping test success from Computer/Bercut <-> RJ45 caple <-> 88E1111<-> SGMIII<-> TSE IP. Can you help me change to project test to Computer/Bercut <-> SFP Caple <-> SFP 1G module<-> XCVR<-> TSE IP? Thank so much! My project test is below. https://drive.google.com/file/d/1aZt2EIvVLVoqDmtknu724jLimWsUk57V/view?usp=sharing

TRAN_HIEU_007
Beginner
76 Views

Hi SengKok. I have been tried "AN744: Scalable Triple Speed Ethernet Reference Designs for Arria 10 Devices" but projet not ran in TEST_1588 0 1 1G test in above. In project "Single-Port Triple-Speed Ethernet and On-Board PHY Chip Reference Design - Arria 10 " TSE run in SGMII interface with 88e1111. But I need interface with SFP port.

SengKok_L_Intel
Moderator
57 Views

If the SMA loopback on channel 0 is passing, then please focus on your hardware setup first.

TEST_SMA_LOOPBACK 0 1G 1000 


Please check if the channel 0 SFP loopback is passing.

TEST_1588 0 0 1G


TRAN_HIEU_007
Beginner
11 Views

I can't sucess this test. I'm not sure that the Cyclone 10gx supports 1G SFP communication or I have misconfigured IPCore TSE. Can you help me try the above example on a Cyclone10gx kit. If that fails I fear that having to switch to using Xilinx IC:

Reply