Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Valued Contributor III
709 Views

Cyclone III Development Board Failure

I have a Cyclone III Development board that has suddenly stopped working. Before the failure, I was able to see the Power Display working correctly, and I was able to connect a USB cable to the board and program the Cyclone III FPGA.  

 

At some point, I attempted to reprogram the FPGA with the USB-Blaster, and the Quartus II programmer stalled. So I clicked the "Stop" button to discontinue the load, but the programmer was still stalled. Then I waited for some time before powering down the board - the programmer was still stalled. After waiting some more time, I finally disconnected the USB cable.  

 

When I powered up the board again, the voltage display was not working, and the "LOADING", "ERROR", and "USER" LEDs are all dimly lit. This occurs with or without the USB Blaster cable. Further, I could not program the FPGA via the USB Blaster - the JTAG chain debugger returns two errors: "JTAG chain problem detected" and "No device detected".  

 

Here is what I have tried since then... 

1. Thinking the issue was with the Max II device, I reprogrammed it (with a Byte-blaster cable) with the m2_prod_1337.pof update from the Altera website. The program loads successfully into the Max II, but the symptoms on the board persist. 

 

2. Thinking the issue might be with the USB Blaster circuitry, I tried using the Byte-Blaster cable to program the FPGA directly by following table 2-7 of the reference manual that discusses JTAG settings. The JTAG Chain debugger returns the same two errors as before: "JTAG chain problem detected" and "No device detected".  

 

Before I conclude that the FPGA on the board is damaged and throw it away, I would like a second opinion, as well as any other ideas for things to try... 

 

Thanks very much, 

E
0 Kudos
1 Reply
Highlighted
Valued Contributor III
6 Views

It turns out that these symptoms were caused by something malfunctioning on the 2.5V supply. After some trial and error, I determined that the malfunction was on the 2.5V circuit that powers banks 5&6 of the FPGA. The rest of the board functions correctly when R51 is removed.  

 

To further troubleshoot the problem, I tried disconnecting everything besides the FPGA that was powered by 2.5V_B5_B6: bypass capacitors, analog mux (U35 pin 31). Unfortunately, removing the capacitors (and lifting U35 pin 31) did not solve the problem. So I am pretty sure that banks 5/6 of the FPGA must have suffered some internal damage that causes a short on this circuit. I'm posting this in case someone has an idea for something else to try. 

 

Thanks very much, 

E
0 Kudos