Community
cancel
Showing results for 
Search instead for 
Did you mean: 
SSmit7
Novice
436 Views

Cyclone V GT board test system not functional

Hello 

I have been trying to get the basic board test system up and running for the Cyclone V GT development kit. I am running it on Quartus 13.0.1 (service pack 1). I can connect to the board via the Ethernet interface, I am able to upgrade the board files using that interface as well. I am unable to configure the board for the board test software however, and therefore I cannot run the board test software. I have already done the following:

- I have ensured that the DIP switches are in their default positions.

- I have followed the quick start guide to get the board test system working.

- I have followed the manual to get the board test system working.

- I have generated a bt_config.flash (and successfully programmed it to the correct memory location).

When I initialise the board test system (with either the factory default configuration or the bt_config configuration) I receive the error shown in ImageA.PNG.

If I try to configure the board with one of the four test images, then I get the error shown in ImageB.PNG (the device cannot successfully configure).

Please can someone help with this. I cannot get anything working and it is very frustrating for an off-the-shelf product. Thanks in advance.

0 Kudos
11 Replies
AR_A_Intel
Employee
410 Views

Hi Sir

 

Welcome to INTEL forum. May we know, is this the board that you refer to? https://www.intel.com/content/www/us/en/programmable/products/boards_and_kits/dev-kits/altera/kit-cy...


SSmit7
Novice
402 Views

Hello

Yes, this is the board that I am using.

AR_A_Intel
Employee
397 Views

Hi

 

Thanks for update. But before setting up BTS, would you kindly help check whether your machine is supported or not (OS) by referring to link below: https://www.intel.com/content/www/us/en/programmable/support/support-resources/download/os-support.h...  

An unsupported platform means that some things may work, but others not, and we won't put any resources into debugging or diagnosing. We strongly recommended to use the right OS as it was tested.

 

2. Could you attach again the error screenshot?

 

Thanks


SSmit7
Novice
393 Views

Hello

I am using Quartus version 13.0 SP1 with the dev board. The board test software doesn't seem to work with a later version of Quartus that I tried (17.1). The system requirements for Quartus version 13.0 SP1 are as follows (from the Quartus readme.txt file):

"System Requirements
===================
Operating system support
------------------------
* Windows 7 (64 and 32 bit)
* Windows XP SP2 (64 and 32 bit)
* Windows XP Pro X64 Edition
* Windows Server 2008 R2 (64 bit)
* Red Hat Enterprise Linux 6 (64 bit)
* Red Hat Enterprise Linux 5 (64 and 32 bit)"

I am using Windows 7 SP 1 64 bit. I believe that this means that it should work, surely, according to the system requirements?

SSmit7
Novice
386 Views

Here are the error screenshots again, as requested.

AR_A_Intel
Employee
352 Views

Hi

Done checking with teammate, for Image A – No BoardTestSystem-compatible design exists in FPGA

  •             This looks like you didn’t select the default BTS design?

Could you help check? Did you select and load the BTS example design from BTS software?

  •             And may I know, have you change/program the default Max V pof design? For instance : Reprogram the Max V with your own design 
SSmit7
Novice
345 Views

Hello

Done checking with teammate, for Image A – No BoardTestSystem-compatible design exists in FPGA

  •             This looks like you didn’t select the default BTS design?

Could you help check? Did you select and load the BTS example design from BTS software?

As I said in my first message, yes, this is the first thing that I tried. That is the problem, the default or test bts_configuration files simply do not work. Here's the quote from my first message: "When I initialise the board test system (with either the factory default configuration or the bt_config configuration) I receive the error shown in ImageA.PNG."

And may I know, have you change/program the default Max V pof design? For instance : Reprogram the Max V with your own design 

No, I have not reprogrammed any of the devices besides the Cyclone V GT.

 

AR_A_Intel
Employee
339 Views

Hi

 

Thanks for you update. For Image B – (failed to configure, conf_done did not go high). This error message means failed to program design into FPGA. May I know, has this board ever working before? Because the symptom it shows, more to faulty dev kit board?

 

Could you help check and try program with your own Quartus design first, don’t use BTS design. This is to verify whether the dev kit board still functional or not. Provide screenshot of your tasting.


SSmit7
Novice
329 Views

Hello

When I received the board the first thing that I tried to do with it was to get the board test software working and I was unable to do so, so it's possible that the board is non-functional in some way related to the board test. However, I have been able to program PCIe benchmarking firmware into the correct location and successfully configure the FPGA.

Perhaps the problem is that the bt_config project that I have access to is not correct? I used the one available from the Intel website. Is there a different one that I should be using?

Regards

 

AR_A_Intel
Employee
313 Views

Hi Sir

 

At this point, most probably it could be board error as we can’t replicate the issue with our board. We recommended for RMA. Could you help provide the following for warranty checking before RMA process?

 

Name:

Email Address:

Company/University Name:

Dev kit OPN :

Serial Number :

 

A copy of invoice that shows time and date of purchase. You may reply/attach your file in private message for privacy purpose.


AR_A_Intel
Employee
242 Views

We do not receive any response from you to the previous reply that I have provided. This thread will be transitioned to community support. If you have a new question, feel free to open a new thread to get the support from Intel experts. Otherwise, the community users will continue to help you on this thread. Thank you


Reply