Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
864 Views

DE 1 not programming and getting Terasic_download.dll erorr runing control_panel

Hello, 

I'm struggling trying to send a simple design *.sof file the the terasic DE1 board with the cyclone II. I am running windows 10, using Quartus II 13.0sp1 64bit web edition. I updated the USB blaster driver. The programmer sees the usb blaster and everything seems to work correctly. The programmer interface allows me to find set everything up correctly and press start. The Auto detect It progressed and says it it 100% done. The default program on the board stops. But my program/configuration does not work. ( it is the simple verilog program to map switches to LED's). I cycle power and the default program starts up. 

 

This may be related when I try to run the contol_panel program that comes with the board it does not work. The gui is load and it looks like it is tying to download the .sof file that is associated with the program but I get an error that the TERASIC_DOWNLOAD.dll has and error. 

 

 

Any suggestions? 

 

Thanks,
0 Kudos
1 Reply
Altera_Forum
Honored Contributor I
20 Views

Hi,  

 

If you have set the RUN/PROG switch to the RUN position when executing the default code, the .sof file should be downloaded properly. Maybe there is something wrong with your project, it is suggested that you test the project in Terasic CD-ROM (the CD can be downloaded from the web link: http://www.terasic.com.tw/cgi-bin/page/archive.pl?language=english&categoryno=53&no=83&partno=4), if you can run Terasic project successfully, please double check if you have set the pin assignments, reset state and clock in your own project correctly or not. 

 

In addition, please download the latest ControlPanel version (DE1 Control Panel V2.1.0) from the link: http://www.terasic.com.tw/cgi-bin/page/archive.pl?language=english&categoryno=53&no=83&partno=4

 

If the solution above is still failed, you could send the description of your problems (with corresponding screenshots) to Terasic support team (support<support@terasic.com>). 

They would be very happy to help.  

 

Barbara