Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
1,081 Views

DE0 NANO SoC rev.B Can't access JTAG chain

As per the title, when I try programming the device I started lately to get the following error: 

 

Error (209040): Can't access JTAG chain Error (209015): Can't configure device. Expected JTAG ID code 0x02D010DD for device 2, but found JTAG ID code 0x00000000. Make sure the location of the target device on the circuit board matches the device's location in the device chain in the Chain Description File (.cdf). Error (209012): Operation failed  

 

The project was working fine before, since I started using the SignalTap debugger this problem randomly pops up, and when it does the only solution is to create a new project from scratch, copy all the source file and scripts and resume work from there, as the error doesn't manifest itself for a day or so. The problem started when I started to use the Signaltap heavily (but i used it a couple of times before and all was working so I don't know if the two things are related).  

 

When I first run quartus the JTAG chain debugger test passes with the following message: 

 

!Info: JTAG chain connection is good. Detected 2 device(s)!Info: Device 1: SOCVHPS (USERCODE: - ) !Info: Device 2: 5CSE(BA4|MA4)/5CSXFC4C6 (USERCODE: 0xFFFFFFFF)  

 

if I then try to program the device the aforementioned problem pops up and any subsequent test triggers the following error message: 

 

Unable to scan device chain. Hardware is not connected.  

 

I already tried the following: 

 

-To rule out any Hardware problem I tried flashing one of the kit's example projects and it works flawlessly. 

-Checking on the windows device manager shows the onboard usb blaster is still connected and working. 

-I haven't modified any pin assignment or SDC constraint so that can't have triggered the problem, I also tried rerunning all the pin assignment scripts but that did not change anything 

-I removed the sdc constraints file and nothing changed 

-I deleated all the generated files and folders (the platform designer output ones, incremental_db, db simulation, *.sopcinfo, *.qsf *.stp) but nothing changed 

 

As you might immagine having to recreate the project at least daily due to this bug is extremely annoying and severely limits my productivity. 

 

I'm using Quartus prime lite 17.1.1 Internal Build 593 on windows 10 x64
Tags (1)
0 Kudos
2 Replies
Altera_Forum
Honored Contributor I
177 Views

To rule out the board, how many times did you try programming with the example project you mention? If this is an intermittent hardware issue, it could show up later even with an example project. 

 

Does simply power cycling the board have any effect? Or unplugging and re-plugging USB?
Altera_Forum
Honored Contributor I
177 Views

I tried to program the example many times (i haven't counted but at least 10) ant the problem is definitively related to the project 

 

Also with further investigation the culprit seems to be the indeed the qsf file, by replacing it with a known good one ( one from a newly created project) the problem goes away 

 

I still don't know how that file got corrupted, I'm suspecting it has to do with SignalTap
Reply