Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
768 Views

DE0-Nano Problem booting into Linux using examples

Hi,  

I followed instructions in "DE0-Nano-SoC_Getting_Started_Guide" and it was fine until Chapter 5.4 Running Linux on DE0-Nano-SoC board.  

 

I think I have followed the instructions strictly but perhaps somewhere went wrong. 

 

Symptom:  

When I opened PuTTY and started a serial session, PuTTY gave me a black console. Nothing was there except a small green block. Where it should be some booting info and wait me to type "root" to log in. 

 

What I have noticed/tried:1. In Section 5.2 (preparing microSD card), I found the unzipped image "DE0_Nano_SoC_Linux_Console.img" cannot be mounted by windows. I tried downloading multiple times, and it did not help. 

2. In the same section, I noticed that the volume of prepared microSD card had been changed. The kit I purchased comes with a 4GB microSD and it became 817 MB after using Win32 disk imager. Same thing happened to another SD card of mine.  

3. The prepared microSD contains following files/folder: 

a. Temp (empty folder, probably generated by my zip software) 

b. de0_nano_soc.rbf 

c. socfpga.dtb 

d.u-boot.scr 

e.zImage 

The total size of these files is merely about 6 MB. I suspect something is missing. 

4. When PuTTY gave me a black screen, I detached the usb on the DE0_Nano side while leaving the usb cord connected to the laptop. And the PuTTY did not give any error.  

5. When I open the port COM4 (the port for my DE0_Nano), the default speed was 9600 instead of 115200. My setting on PuTTY was 115200. I have tried both speeds but didn't help. 

 

How can I fix this problem? Thank you.
0 Kudos
1 Reply
Altera_Forum
Honored Contributor I
46 Views

It has been solved. I did not insert microSD card properly. That's it.

Reply