FPGA, SoC, And CPLD Boards And Kits
FPGA Evaluation and Development Kits
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.

DE2 KIt

Altera_Forum
Honored Contributor II
1,335 Views

Hi all 4rum! 

 

I'm running a VGA labs. The problem that is I just have one single LCD monitor, so I decide buy a data transfer switch box. However, when I connect to my KIT(DE2), it can't show on the monitor, rather remains in black and sign signal led on the monitor at that time is flashing periodically. Unfortunately, when I directly plug monitor cable to the KIT, no longer is it display DE2 default screen.  

 

Anyone can give me the reason tho my VGA port on the KIT ? 

 

Thanks a lot!
0 Kudos
6 Replies
Altera_Forum
Honored Contributor II
157 Views

Please rephrase in better english nad add some more sentence to explain your problem. 

What exactly is the data transfer kit that you bought?
Altera_Forum
Honored Contributor II
157 Views

Sorry for your impatient. I describable in detail as follow: 

 

I want to do some experiments to VGA port in KIT DE2, so firstly I use a demo program for VGA which is provided by Altera. More specifically, this program is belong to DE2_control_panel.  

 

Because I just have one monitor, so I need to unplug VGA cable from PC then connect it to VGA port on DE2 Kit to evaluate the result of the demo. Apparently, it is inconvenient and then I bought a switch permit to connect many PC to a monitor. At the first time, it worked but the second time test was fail. The default theme of DE2 is not displayed on the screen. I noticed that the signal led on the monitor is flash between yellow and green. (When the monitor does not get signal the led is yellow, otherwise it is in green) 

 

I guess VGA port in DE2 kit have got a trouble but I dont know how to fix it. I hope you give me some hints. 

 

Thank
Altera_Forum
Honored Contributor II
157 Views

In an afford, I try some other VGA programs and fortunely, in the stuff of them, one is work. I took it from the source below http://www.johnloomis.org/digitallab/, while demos which companion to the KIT DE2 are fail.  

 

this problem have not happened before I setup a switch for two cable to my LCD monitor. 

 

I guess that DE2 kit get some wrong to the synchronous output. But what cause to it ?
Altera_Forum
Honored Contributor II
157 Views

At the moment, to represent some simple image on LCD vga monitor, I need to use VGA_sync module. While the demos in attached CD is useless since I use a Data Transfer Switch. Sometime, It works but almost time not. I keep my ideal that my DE 2 Kit get something wrong to Hardware, but I dont know where problem is ?

Altera_Forum
Honored Contributor II
157 Views

Ok 

I will try to give you an advice
Altera_Forum
Honored Contributor II
157 Views

thanks for any your support

Reply