Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Valued Contributor III
823 Views

Download the software image Problem

Hi, there 

 

When I download the software image .elf file on the board. It shows the following error: 

 

There are no Nios II CPUs with debug modules available which match the values specified. Please check that your PLD is correctly configured, downloading a new SOF file if necessary. 

 

And when I tried to follow the steps on the Nios II Development Kit Getting Started User Guide, the same problem occurs when I downloaded and run the Executable Code to the Nios Development Board. Could anyone give me a hint how to solve it? Since the downloading for the hardware image is ok, I assume the JTAG cable should be fine. Am I right?
0 Kudos
4 Replies
Highlighted
Valued Contributor III
6 Views

I think I figure out what the problem is. It turns out my external power adapter may not provide enough current. Now this error has been solve. But now the system displays another error like following: 

 

using cable "usb-blaster [usb-0]", device 1, instance 0x00 

pausing target processor: ok 

reading system id at address 0x021208b8:  

id value does not match: read 0x377e31a2; expected 0x32aea7ef 

timestamp value does not match: image on board is older than expected 

read timestamp 3:15:53 2009/10/22; expected 9:53:01 2010/03/10 

the software you are downloading may not run on the system which is currently 

configured into the device. please download the correct sof or recompile. 

restarting target processor 

 

I am working on it, and try to figure it out ASAP.
0 Kudos
Highlighted
Valued Contributor III
6 Views

it looks like the sof file isn't the correct one. 

When you compile your software, the .ptf file from the SOPC system is read to get the hardware configuration (address and interrupt map, devices...). It is very important that the sof file that you upload to the FPGA is compiled with the same hardware description. The error message that you have says that they don't match. 

 

Try to recompile both the Quartus project and the software, and see if you still have the problem. Check also that the software compilation uses the correct .ptf file.
0 Kudos
Highlighted
Valued Contributor III
6 Views

I get same error , and I could not fix the problem....Which ptf file I should embedded before RUN command.... 

"Spoc Builder output ptf file" or "quartus project ptf" file what is the solution?:(
0 Kudos
Highlighted
Valued Contributor III
6 Views

there is no quartus project ptf, just a .ptf file generated by SOPC builder. This is the one to use (or .sopcinfo if you are using the SBT)

0 Kudos