Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
1,344 Views

EMIF on Stratix 10 Dev Kit miss board file

Hi all 

 

i'm working on EMIF for stratix 10 Dev KIT 

while generating the IP i can't find my board listed in the presets  

how can i add it ? 

if i can't what should i do ? 

 

Thanks
0 Kudos
6 Replies
Altera_Forum
Honored Contributor I
65 Views

Hi, 

Which Quartus Version & Edition are you using? 

Check the availability of supported devices & then download it, 

https://www.altera.com/downloads/download-center.html 

 

Let me know if this has helped resolve the issue you are facing or if you need any further assistance. 

 

Best Regards 

Vikas Jathar  

(This message was posted on behalf of Intel Corporation)
Altera_Forum
Honored Contributor I
65 Views

i'm using quartus pro 17.1  

and i'm facing problem generating a working EMIF example design  

is there a portable preset that i can use ?
Altera_Forum
Honored Contributor I
65 Views

Hi, 

 

--- Quote Start ---  

while generating the IP i can't find my board listed in the presets  

--- Quote End ---  

 

Currently it is not available, In future it might get available. 

 

--- Quote Start ---  

if i can't what should i do ?  

--- Quote End ---  

 

You can download Golden Top Design, extract it & open .qpf file from your Quartus tool: (es edition, 17.1 (https://www.altera.com/content/dam/altera-www/global/en_us/support/boards-kits/stratix10/fpga/strati...)) 

https://www.altera.com/products/boards_and_kits/dev-kits/altera/kit-s10-fpga.html 

 

Let me know if this has helped resolve the issue you are facing or if you need any further assistance. 

 

Best Regards 

Vikas Jathar  

(This message was posted on behalf of Intel Corporation)
Altera_Forum
Honored Contributor I
65 Views

Hi , 

 

i have already downloaded the package and tried generating several example designs and i always get calibration failed and i can't "create memory interface connection" in the EMIF Toolkit , so i can't even debug my design  

 

i already posted my problem about "create memory interface connection" you can find it in this link : 

https://www.alteraforum.com/forum/showthread.php?t=59053 

 

and could you please provide me with a full datasheet of the daughter cards that came with the board : 

-ALTERA DRAM X72 DAUGHTER CARD  

-ALTERA RLDRAM3 X36 DAUTHER CARD  

-ALTERA EMIF HILO 

 

i have also tested the examples in the package after downloading the bit stream , in the ISSP i have calibration fail and i tried to run Board Test System (bts) but the gui can't detect the jtag cable  

 

so i'm facing so many problems , i don't have much time and i need help  

 

thanks
Altera_Forum
Honored Contributor I
65 Views

Hi, 

--- Quote Start ---  

i have already downloaded the package and tried generating several example designs and i always get calibration failed and i can't "create memory interface connection" in the EMIF Toolkit , so i can't even debug my design 

--- Quote End ---  

Refer the User guide, 

https://www.altera.com/content/dam/altera-www/global/en_us/pdfs/literature/ug/ug-20120.pdf  

For Daughter cards refer the following link, 

https://www.altera.com/products/boards_and_kits/daughter-cards.html  

 

--- Quote Start ---  

i have also tested the examples in the package after downloading the bit stream , in the ISSP i have calibration fail and i tried to run Board Test System (bts) but the gui can't detect the jtag cable 

--- Quote End ---  

 

Have you installed the drivers, if not, Refer following link & install before using it, 

https://www.altera.com/support/support-resources/download/drivers/dri-index.html 

https://www.youtube.com/watch?v=wjwkdznh1py  

 

Best Regards 

Vikas Jathar  

(This message was posted on behalf of Intel Corporation)
Altera_Forum
Honored Contributor I
65 Views

Hi , 

 

--- Quote Start ---  

 

For Daughter cards refer the following link, 

https://www.altera.com/products/boards_and_kits/daughter-cards.html  

 

--- Quote End ---  

 

there are no memory daughter cards for stratix 10  

 

 

--- Quote Start ---  

 

Have you installed the drivers, if not, Refer following link & install before using it, 

https://www.altera.com/support/support-resources/download/drivers/dri-index.html 

https://www.youtube.com/watch?v=wjwkdznh1py 

 

--- Quote End ---  

 

 

and i already installed the driver and it is working correctly , i'm using it to download the bit stream 

so same problems 

 

thanks
Reply