FPGA, SoC, And CPLD Boards And Kits
FPGA Evaluation and Development Kits
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
4953 Discussions

Error(20072): Incorrect VID settings

Ppavan
Beginner
392 Views

Hi,

I see the following errors while programming the Stratix 10 MX board :

 

1. Error(18950): Device has stopped receiving configuration data 
2. Error(18948): Error message received from device: Detected hardware access error. There is a failure in accessing external hardware. (Subcode 0x0032, Info 0x00000000, Location 0x0000B400)
3. Error(20072): A PMBUS error has occurred during configuration. Potential errors: Incorrect VID setting in Quartus Project. The target device fails to communicate to smart regulator or PMBUS Master on board.
4. Error(209012): Operation failed
 
I am using Quartus 19.2 Prime Pro version. The device ID is  1SM21BHU2F53E2VGS1.
 
I checked multiple places online. I have tried adding extra power management settings in the qsf file, but none of them worked. Kindly help me in resolving this issue.
Thank you.
0 Kudos
5 Replies
NurAiman_M_Intel
Employee
323 Views

Hi,


Thank you for contacting Intel community.


Have you try the solution provided in Intel KDB below:

https://www.intel.com/content/www/us/en/support/programmable/articles/000076902.html


Let us know your feedback.


Regards,

Aiman


Ppavan
Beginner
296 Views

Hi Aiman,

I have already tried the solution you shared.

The same error still exists.

Regards,

Pavan

NurAiman_M_Intel
Employee
268 Views

Hi Pavan,


The error occur due to VID setting.


To have the correct setting please refer to the checklist here:

https://www.intel.com/content/dam/www/programmable/us/en/pdfs/support/devices/SmartVID/Smart-VID-Che...


I tis very crucial to check and confirm the first to line in the QSF file:

 set_global_assignment -name USE_PWRMGT_SDA SDM_IO11

 set_global_assignment -name USE_PWRMGT_SCL SDM_IO14


Please confirm the correct pin is connecting to your hardware. The SDM_IO pin is depending on your pin setting.

It can be IO1- IO16.


Please ensure the pin is set accordingly to your connection.


Regards,

Aiman




Ppavan
Beginner
204 Views

Hi,

The problem has been resolved and now we are able to program the device.

Thank you very much for the help.

 

NurAiman_M_Intel
Employee
180 Views

I’m glad that your question has been addressed, I now transition this thread to community support. If you have a new question, feel free to open a new thread to get the support from Intel experts. Otherwise, the community users will continue to help you on this thread. Thank you.


Reply