FPGA, SoC, And CPLD Boards And Kits
FPGA Evaluation and Development Kits
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
5281 Discussions

Ethernet interface not working on Max10 eval board with Linux

Honored Contributor II



I have an Altera MAX10 10M50 Rev C Development Kit that want to setup under Linux. I have found the instructions below to set it up: https://rocketboards.org/foswiki/documentation/alteramax1010m50revcdevelopmentkitlinuxsetup 


It is working mostly: the board boots, and I can access the shell via the UART. The problem I have is I can't get the ethernet port to work. The PHY seems to be up (one LED lighted and the connection status is "up" as seen from the PC. 

I have tried forcing a static address with "ifconfig up" to no avail. I have attached the boot log for reference. 


Any help will be greatly appreciated. 


Best regards 

0 Kudos
1 Reply
Honored Contributor II

Ok, my bad... 

eth0 is connected to port A, and I was plugged in port B.... 

Problem solved.