Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
1,092 Views

Flash Connection Problem

Hi there, 

 

I use the Altera EP3C120F780 Development board, and try to load files into the onboard flash memory. 

therefore i build a project in the (in the Screenshot). 

if i try to get the cfi-table like its explained in the flash-programmer-pdf i just get no-cfi table found at (base address). 

Base-address should be right, also the sopc-system but im not sure of the timings 4 the flash-memory-controller in the sopc.  

i looked in the datasheet of the flash device 4 the timings and thought that the timings should be setup:75ns; wait:35ns; hold:35ns but im not sure.  

and there is another problem if i use a clock higher then 50MHz 4 the NIOS2 it dont responds so i use 50MHz 4 the NIOS2 and 200MHz 4 the flash-controller( i also tried 50 MHz).  

 

if anybody got a clue, pls help i trying since 2 days -.- 

 

greets 

 

0 Kudos
3 Replies
Altera_Forum
Honored Contributor I
70 Views

I still cant get any response from the flash, i also put Data(0) PIN of my output from the SOPC system floating.  

Is noone of Altera here who got a clue? 

Is sth with the board wrong? 

or is the flash memory not accassable?
Altera_Forum
Honored Contributor I
70 Views

What Quartus version ? 

There was a problem solved in 9.0
Altera_Forum
Honored Contributor I
70 Views

its version 9.1 

 

but i think i got the solution. the pin READ_busy was connected with READ_N of my design. but there are still some problems with the timing i think it should be setup:35ns; wait:75ns; hold:35ns if i interpretet the datasheet right but i dont get the CFI-table correct.  

maybe im wrong or i've missunderstood the timings or could it be that the setup times of the datasheet are not right ones cause i thougt it should be the flash with 110 ns Readcycle time. 

 

thx 4 reply 

Reply