FPGA, SoC, And CPLD Boards And Kits
FPGA Evaluation and Development Kits
5780 Discussions

HELP!!! Qsys PCIE miss interrupt

Altera_Forum
Honored Contributor II
995 Views

I run the "PCI_Express_in_Qsys_Example_Designs" sample on "Cyclone IV GX starter kit" board. 

Running SGDMA successed. 

 

I want to know wheather DMA is ended by using interrupt. But i can't get the interrupt notification all the times. 

 

Environment is: 

WindowsXP SP3 

Jungo WinDriver 

PCIE send "legacy level-sensitive interrupt" 

Steps: 

1. enable interrupt at 0x0050 register 

2. clear interrupt state 0x0040 

3. useing WDC_IntEnable register IntHandler function 

4. listen in IntHandler function 

5. clear 0x0040 interrupt state in intHandler function 

6. printf("Got a interrupt\n") in IntHandler function 

I can't get the interrupt all the times. 

I also got the same result by using "MAILBOX" testing.
0 Kudos
5 Replies
Altera_Forum
Honored Contributor II
280 Views

Hi, 

I am also facing the same issue while configuring Legacy interrupt. Have you got any solution to this problem? If you can share your experience it will be graet help:) 

 

Thanks, 

Chandra
0 Kudos
Altera_Forum
Honored Contributor II
280 Views

hi, 

can u help me how to use mailbox registers for interrupts 

 

thanks,
0 Kudos
Altera_Forum
Honored Contributor II
280 Views

What version of Quartus are you using?  

 

Some of the earlier versions (11.0 ....) had problems with interrupts, if you search my posts in the forums you'll find where 

I've described the problems I've had. 

 

I think that 12.0 and later versions are working OK. 

 

 

Nial
0 Kudos
Altera_Forum
Honored Contributor II
280 Views

hi nial, 

 

am using quartus 12.0
0 Kudos
Altera_Forum
Honored Contributor II
280 Views

 

--- Quote Start ---  

I run the "PCI_Express_in_Qsys_Example_Designs" sample on "Cyclone IV GX starter kit" board. 

Running SGDMA successed. 

 

I want to know wheather DMA is ended by using interrupt. But i can't get the interrupt notification all the times. 

 

Environment is: 

WindowsXP SP3 

Jungo WinDriver 

PCIE send "legacy level-sensitive interrupt" 

Steps: 

1. enable interrupt at 0x0050 register 

2. clear interrupt state 0x0040 

3. useing WDC_IntEnable register IntHandler function 

4. listen in IntHandler function 

5. clear 0x0040 interrupt state in intHandler function 

6. printf("Got a interrupt\n") in IntHandler function 

I can't get the interrupt all the times. 

I also got the same result by using "MAILBOX" testing. 

--- Quote End ---  

 

 

I want to know wheather DMA is ended by using interrupt. But i can't get the interrupt notification all the times. 

Hi yanshine, 

 

I'm wondering if you got through your problems. I am seeing the same issue on my board using a stratixV device. Its 3 years ago, but I'm hoping you have some knowledge to share. 

 

-V
0 Kudos
Reply