Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
110 Views

How do I get Arria10 design to compile on Quartus 18.1.2?

I recently downloaded the Arria 10 device on my Quartus18.1.2. The problem I run into is that it seems to require Quartus18.1.0 based on this compilation error :

 

Error(114006): Database file c:/altera/18.1/quartus/common/devinfo/20nm/ddb_nightfury_info.ddb, created by Quartus II Version 18.1.0 Build 222 09/21/2018 SJ Pro Edition software, not compatible with current Quartus Prime Version 18.1.2 Build 277 02/12/2019 SJ Pro Edition software 

 

 

This only happens on Arria10 because I can compile with Stratix10 and Cyclone10.

 

Thanks

0 Kudos
5 Replies
Highlighted
Retired Employee
20 Views

Since you installed Arria 10 after patching 18.1, the software might be messed up. I'd uninstall Quartus, re-install it, installing A10 at the same time, and then patch to 18.1.2 last.

 

#iwork4intel

0 Kudos
Highlighted
Employee
20 Views

Hi Vuk,

 

Did you have the base software installed first? Then you installed the 277 patch?

 

Best Regards,

Isaac.

0 Kudos
Highlighted
Beginner
20 Views

Hello all,

 

yes that's what i did, i installed 18.1 (which is 222) then patch to 277. After that i installed arria10 device. I could follow sstrell advice but any work around so i dont have to uninstall?

thanks

0 Kudos
Highlighted
Employee
20 Views

Hello Vuk,

 

I have a workaround for you. Could you please uninstall the patch? Then you have the base of Quartus, install the Arria 10 device.

 

After you complete this, you can install the patch again and try to compile it again.

 

To uninstall the patch look follow the next link [1].

 

[1] https://www.intel.com/content/www/us/en/programmable/support/support-resources/knowledge-base/soluti...

 

Best regards.

Isaac.

 

0 Kudos
Highlighted
Employee
20 Views

Hello Vuk

 

Did the solution work?

 

Best regards,

Isaac.

0 Kudos