Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
1,094 Views

I'm having difficulty with ssh to new Arria 10 SoC Dev Kits

We just purchased 8 of the Intel Arria 10 SoC Development Kits (not GX). I've tried several Arria 10 Dev Kits and all are behaving the same way. I setup a nat network behind my laptop with DHCP and the board intermittently displays the IP address on the LCD. Sometimes the LEDs near C70 never blink (four solid lights) and the LCD is blank, so I have to do a warm boot repeatedly until the boards to come up. When the LEDs cycle and the LCD displays either an IP address or No IP address, I check the DHCP server logs and it assigns an address either way. When it does boot up, I can see the web interface and perform all of the tests (LEDs, LCD display, etc.) except ssh to the board. The connection is always closed by the remote computer when I try "ssh root@192.169.0.x", where x is the DHCP assignment. I can get the certificate, so I know the port is open (not an ipchains or other firewall issue). Is there a way to open a terminal through USB or RS232 to see what's happening?

0 Kudos
4 Replies
Altera_Forum
Honored Contributor I
71 Views

I'm getting closer. I found the instructions for the Cyclone V dev board and attached to the TTY located on the UART (J10) with 115200-N-8-1. I picked a brand new unopened box, installed the HPS memory, verified ALL jumpers and switches, and tested it. Now I can see the out of the box Arria 10 SoC Dev kit is getting a kernel panic. So far I've tested 4 of these $4500 dev kits and they are all intermittently getting a kernel panic.  

 

 

mmc0: new high speed SDHC card at address 0007 

mmcblk0: mmc0:0007 SD16G 14.5 GiB  

mmcblk0: p1 p2 p3 

platform leds.2: Driver leds-gpio requests probe deferral 

kjournald starting. Commit interval 5 seconds 

EXT3-fs (mmcblk0p2): using internal journal 

EXT3-fs (mmcblk0p2): recovery complete 

EXT3-fs (mmcblk0p2): mounted filesystem with ordered data mode 

VFS: Mounted root (ext3 filesystem) on device 179:2. 

devtmpfs: mounted 

Freeing unused kernel memory: 332K (8067c000 - 806cf000) 

Kernel panic - not syncing: Attempted to kill init! exitcode=0x0000000b 

 

CPU: 1 PID: 1 Comm: init Not tainted 3.10.31-ltsi-02998-g28bac3e# 1 

[<80016538>] (unwind_backtrace+0x0/0xf8) from [<80012e24>] (show_stack+0x20/0x24) 

[<80012e24>] (show_stack+0x20/0x24) from [<804c39e4>] (dump_stack+0x24/0x28) 

[<804c39e4>] (dump_stack+0x24/0x28) from [<804c1890>] (panic+0xac/0x1f8) 

[<804c1890>] (panic+0xac/0x1f8) from [<80028d34>] (complete_and_exit+0x0/0x2c) 

[<80028d34>] (complete_and_exit+0x0/0x2c) from [<80029c54>] (do_group_exit+0x5c/0xdc) 

[<80029c54>] (do_group_exit+0x5c/0xdc) from [<80037880>] (get_signal_to_deliver+0x298/0x660) 

[<80037880>] (get_signal_to_deliver+0x298/0x660) from [<800122e4>] (do_signal+0x114/0x464) 

[<800122e4>] (do_signal+0x114/0x464) from [<800127bc>] (do_work_pending+0x74/0xb4) 

[<800127bc>] (do_work_pending+0x74/0xb4) from [<8000e6c0>] (work_pending+0xc/0x20) 

CPU0: stopping 

CPU: 0 PID: 0 Comm: swapper/0 Not tainted 3.10.31-ltsi-02998-g28bac3e# 1 

[<80016538>] (unwind_backtrace+0x0/0xf8) from [<80012e24>] (show_stack+0x20/0x24) 

[<80012e24>] (show_stack+0x20/0x24) from [<804c39e4>] (dump_stack+0x24/0x28) 

[<804c39e4>] (dump_stack+0x24/0x28) from [<800144dc>] (handle_IPI+0x120/0x13c) 

[<800144dc>] (handle_IPI+0x120/0x13c) from [<80008590>] (gic_handle_irq+0x68/0x6c) 

[<80008590>] (gic_handle_irq+0x68/0x6c) from [<8000e280>] (__irq_svc+0x40/0x50) 

Exception stack(0x806d1f30 to 0x806d1f78) 

1f20: 80f5c7f8 00000000 00016a7a 00000000 

1f40: 806d0000 806d0008 806d0000 8070b410 806d83e8 806d843c 00000000 806d1f84 

1f60: 806d1f88 806d1f78 8000fa7c 8000fa80 60000113 ffffffff 

[<8000e280>] (__irq_svc+0x40/0x50) from [<8000fa80>] (arch_cpu_idle+0x3c/0x40) 

[<8000fa80>] (arch_cpu_idle+0x3c/0x40) from [<80060b8c>] (cpu_startup_entry+0x148/0x218) 

[<80060b8c>] (cpu_startup_entry+0x148/0x218) from [<804bd28c>] (rest_init+0x84/0x88) 

[<804bd28c>] (rest_init+0x84/0x88) from [<8067cab4>] (start_kernel+0x2b4/0x2c0) 

 

 

 

Does anyone know what's going on? Please help. 

 

See the attachment for the full boot text
Altera_Forum
Honored Contributor I
71 Views

I got it working. I created a new sd card using the instructions on rocketboards for creating a 17.1 gsrd image. It didn't work the first few times, I kept getting errors at different points in the boot. I tried 16.0, 16.1, and then tried 17.1 again and it worked.

Altera_Forum
Honored Contributor I
71 Views

It seems the 16.1 GSRD supports both Arria 10 RevB and RevC boards. You need to make sure which Rev board you have and download the respective files for that board. You may encounter kernel crashes if the linux image/uboot are not matching with the HW specs of the board. Each board with different HW specs will have its own version of Uboot and linux. So please make sure of the board Rev before downloading and booting uboot/linux.

Altera_Forum
Honored Contributor I
71 Views

The SSH implementation on the shipped image is broken! You either need a new SSD image or specify an older cipher: 

 

ssh -oCiphers=aes256-ctr root@arria10.local
Reply