FPGA, SoC, And CPLD Boards And Kits
FPGA Evaluation and Development Kits
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
4971 Discussions

I tried to run RTL sim in cadence tool (ncverilog) and found some encryption files in the libraries. Then, I got some messages as below about the key file. How can I fix it? Thanks.

sjhuo
Beginner
937 Views

The model encrypted file path: quartus/eda/sim_lib/mentor/twentynm_atoms_ncrypt.v

===============================================

file: ../Model/FPGA/a10_model/twentynm_atoms_ncrypt.v

`pragma protect data_block encoding= (enctype="base64", line_length= 76, bytes= 25130288)

                                                                

ncvlog: *F,DECERR (../Model/FPGA/a10_model/twentynm_atoms_ncrypt.v,37|90): Error while decrypting : unable to load key :(NCPROTECT_KEYDB environment variable not set).

ncverilog: *E,VLGERR: An error occurred during parsing. Review the log file for errors with the code *E and fix those identified problems to proceed. Exiting with code (status 2).

TOOL:  ncverilog  15.20-s035: Exiting on Apr 26, 2019 at 10:47:24 CST (total: 00:00:01)

0 Kudos
6 Replies
KhaiChein_Y_Intel
465 Views

Hi,

 

You are running simulation in cadence tool but the simulation library is pointed to Mentor: quartus/eda/sim_lib/mentor/twentynm_atoms_ncrypt.v

 

You have to change to the simulation library to Cadence.

 

Thanks.

KhaiChein_Y_Intel
465 Views
Hi, May I know if you have any updates? Thanks
sjhuo
Beginner
465 Views

​Hi, Sorry for my late reply.

I have solved this using cadence 's twentynm_atoms_ncrypt.v file.

I found that the cadence 's twentynm_atoms_ncrypt.v files. are only available in linux version quartus, not be available in windows version.

but this is not descripted in user-gudie. I suggest this information should be added in user-guide.

Thanks for your support !!

   

KhaiChein_Y_Intel
465 Views

Hi,

 

May I know the edition(Pro/Standard) and version of the Intel Quartus Prime software you are using?

 

Thanks

sjhuo
Beginner
465 Views

Hi, I used Quartus Prime 16 build 211 Standard version.

Thanks!!

KhaiChein_Y_Intel
465 Views

Hi,

 

According to https://www.intel.com/content/www/us/en/programmable/documentation/gft1513990268888.html Table 1:Supported Simulators, Cadence simulator is supported in Linux 64-bit only.

 

Thanks.

 

Reply