Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
784 Views

JTAG ID error

Hi, there 

 

I tried to implement Video-over-IP reference design on the Cyclone II dev kit. The Altera website said this reference design support Cyclone II series dev kit, and my one is EP2C35. But, when I downloaded the hardware image on to the dev KIT, error occurs, and here is the error information: 

 

Error: Can't configure device. Expected JTAG ID code 0x020E30DD for device 1, but found JTAG ID code 0x020B40DD. 

Error: Operation failed 

 

I tried every possible port, and even when I tried to do factory recovery config, the same error still happen. Could anyone tell me what happened? And how should I fix this error? Thanks. 

:confused:
0 Kudos
3 Replies
Altera_Forum
Honored Contributor I
57 Views

The JTAG ID clarifies, that the image is dedicated to Stratix II GX90. It can't run on Cyclone and must be recompiled.

Altera_Forum
Honored Contributor I
57 Views

In the folder, there are two sof file. One is the demo_2sgx, another is demo_4sgx. The manual said the demo_2sgx corresponds to the cyclone edition while the demo_4sgx corresponds to the Stratix series. I tried the demo_2sgx file. Anyway, I will recompile it and report the status. Thanks.

Altera_Forum
Honored Contributor I
57 Views

I recompiled it. Yes, it should be a different .sof file. Now the hardware image works. However, when I download the software image .elf file on the board. It shows the following error: 

 

There are no Nios II CPUs with debug modules available which match the values specified. Please check that your PLD is correctly configured, downloading a new SOF file if necessary. 

 

And when I tried to follow the steps on the Nios II Development Kit Getting Started User Guide, the same problem occurs when I Downloading and run the Executable Code to the Nios Development Board. Could anyone give me a hint how to solve it? Since the downloading for the hardware image is ok, I assume the JTAG cable should be fine. Am I right?
Reply