FPGA, SoC, And CPLD Boards And Kits
FPGA Evaluation and Development Kits
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
5283 Discussions

JTag Issues: Can't Initialize Chain - Error locking chain or hardware is not set

Altera_Forum
Honored Contributor II
1,411 Views

I'm trying to program my DE0-CV board using Quartus 16.1 on Ubuntu and I'm having a lot of trouble getting the usbblaster jtag programming to work.  

 

When I try to program the board with the vga demo files provided by Altera, the programmer hangs and eventually times out reporting that it "Can't access JTAG Chain". I also ran the JTAG Debugger and it reports that it "Can't initialize Chain - Error locking chain or hardware is not set." It's very strange because my computer detects the hardware just fine and the little green status LED even lights up when I begin programming. It just never completes successfully. 

 

Just FYI, I've made sure that non-root users have access to the usbblaster by adding the necessary udev rules. 

I know the issue is nothing related to hardware because I can program the board perfectly fine if I use Windows. 

 

Thanks for the help!
0 Kudos
1 Reply
BRand2
Beginner
395 Views

Did you ever figure this out?

 

I'm having the same issue and would really appreciate the help.

Reply