Community
cancel
Showing results for 
Search instead for 
Did you mean: 
jmoro1
Beginner
248 Views

Malfunction issue with Arria10 GX Development Kit when flash is downloaded with an encrypted file.

Jump to solution

I'm using the Arria10 GX Development Kit. I have video filter function application downloaded in the flash memory at the UserHardware1 memory area on dev kit board. When non-encrypted the board runs correctly . The problem occurs when the function bitstream is encrypted

and downloaded in the flash, (i guess the download process is correct because it is the same download process as non-encryted file) :

1st step = download flash with encrypted file

2 step = download .ekp file in the Arria 10

3 step = push the PGM_CONFIG push button onto load the flash memory image.

 

The FPGA download from the flash begins and the D15 led (load) is green 

then after a few seconds the D16 led (max_error) lights up red .

the D17 led (conf_done) remains off .

There is no picture on the board video output, the Arria 10 seems not downloaded....

 

Did anyone already had to deal with such case ?

 

0 Kudos

Accepted Solutions
YuanLi_S_Intel
Employee
22 Views

Hi JM,

 

I am glad it works. By the way, just to clarify, are you saying that initially, you didnt assign any starting address on Page_0 and it works when you assign SOF to Page_1 with starting address?

 

The Page Properties is just to assign starting address for the bitstream. We only have the guide to use Intel Programmer. It is available at link below:

https://www.intel.com/content/www/us/en/programmable/documentation/ftt1513991830769.html

 

Regards,

YL

View solution in original post

3 Replies
YuanLi_S_Intel
Employee
22 Views

Hi Moronta,

 

D16 lights up means configuration from flash fails. It is due to the programming file. Just would like to check, have you tried to program non-encrypted file before?

 

Also, have you followed the flow to program encrypted file as shown at user guide below?

https://www.intel.com/content/dam/www/programmable/us/en/pdfs/literature/an/an556.pdf (Page 12)

 

Regards,

YL

jmoro1
Beginner
22 Views

Hi YL ,

 

first of al I'm going to reply to your answers :

 

==> non-encrypted file : Yes I began by downloading non-encrypted files an d the board runs as expected with non-encrypted files.

==> AN556 : Yes , I 've followed the flow to program encrypted file as shown in the AN556.

 

Then I"m going to add that since yesterday i've succeeded in programming the flash with encrypted file and download properly the fpga , these are the steps :

First as I had the issue I noticed the encrypted file was downloaded in the Flash Factory Hardware memory area instead of UserHardware1 memory area .

Then looking for an explanation for this wrong start @ddress I found that in the Convert Programming File window the SOF Data Properties was at its default value : Page Property = Page_0.

That was the cause of the issue .

Then I generated the Flash programming file with the right parameters onto target the UserHarware1 area :

in the Convert Programming File window => SOF Data Properties = Page_1

+ in the Convert Programming File window => SOF Data start_adress = start 0x02D00000

 

Next I downloaded the Flash with this new .POF file

Finally I downloaded the Arria 10 with the generated .ekp file

The result was a right configuration of the FPGA and the board succeeded in supplying a picture as expected .

 

(I've tried to target the UserHardware 2 memory area with those parameters :

in the Convert Programming File window => SOF Data Properties = Page_2

+ in the Convert Programming File window => SOF Data start_adress = start 0x05800000

Result = board runs correctly . )

 

 

Thank you for your answer YL,

feel free to comment my post,

by the way do you know if there is an Application Note or a White Paper that describes more accurately

the Page Properties Settings ?

 

Kind regards ,

JM

YuanLi_S_Intel
Employee
23 Views

Hi JM,

 

I am glad it works. By the way, just to clarify, are you saying that initially, you didnt assign any starting address on Page_0 and it works when you assign SOF to Page_1 with starting address?

 

The Page Properties is just to assign starting address for the bitstream. We only have the guide to use Intel Programmer. It is available at link below:

https://www.intel.com/content/www/us/en/programmable/documentation/ftt1513991830769.html

 

Regards,

YL

View solution in original post