Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
1,221 Views

NEEK Cyclone III edition programming

Hello, 

 

I´m new to Altera and I´m using Nios II Embedded Evaluation Kit (NEEK), Cyclone III Edition.  

 

My first question is: Do I need any programming device betweeen PC and NEEK? I tried connetction with cable, which have on one side USB connector and on the oher side is compatible connector with NEEK board, but PC can´t find any hardware to programm. 

 

Second question is: When I open Nios II - Eclipse, I want to create new Nios II Application form BSP template, than I´m going to choose created BSP file and when I click Finish, there is error "./create-this-bsp --cpu-name cpu --no-make". I tried to open Eclipse in mode Run as administrator but the problem still persists. How can I fix it? 

 

Thank you for yours answers
0 Kudos
7 Replies
Altera_Forum
Honored Contributor I
47 Views

Hi, 

 

1.Turn on the board and check JP8 should be OPEN: USB-Blaster Enable and check 

2.Set compatibility mode or reinstall Nios II - Eclipse and check. 

 

or try with different quartus 13.1. 

 

Best Regards, 

Anand Raj Shankar 

(This message was posted on behalf of Intel Corporation)
Altera_Forum
Honored Contributor I
47 Views

Hello,  

 

1. JP8 is disconnected that provides LF_EN is on logical 1. But I´m trying to use J3 conector and PC can´t find any hardware. 

2. By compatibility mode you mean compatibility with Windows? I tried to change it to compatibility with Win 7, XP and I have changed version of software from 13.1 to 12.1, but the problem stil persist.
Altera_Forum
Honored Contributor I
47 Views

Hello, 

 

1.Yes, that jumper setting is important for hardware to be detected and yes i know you are using j3. 

2.Have you installed programmer?(so that your hardware is detected with auto detect option after turning on the board) 

https://www.altera.com/downloads/software/prog-software/121.html 

3.Try to load sample program like hello world. 

 

Best Regards, 

Anand Raj Shankar 

(This message was posted on behalf of Intel Corporation)
Altera_Forum
Honored Contributor I
47 Views

Hi, 

 

Yes, I have installed programmer, but hardware is still undetectable. 

Can I load any program without connection?
Altera_Forum
Honored Contributor I
47 Views

Hi 

 

--- Quote Start ---  

 

Yes, I have installed programmer, but hardware is still undetectable. 

 

--- Quote End ---  

 

1.Is USB Blaster driver installed properly? (check in device manger and also check other thread for more information on drivers) 

 

Best Regards, 

Anand Raj Shankar 

(This message was posted on behalf of Intel Corporation)
Altera_Forum
Honored Contributor I
47 Views

Hi, 

 

thank you for support, driver is instalation was sucesfully. I had to manually show the driver a path to the driver. But one error is still persists.. When I open Eclipse, click on New, than Nios II Application and BSP from Template, in window choose file.sopcinfo and click on finish, there is error "./create-this-bsp --cpu-name cpu --no-make". It is the same on version 13.1 and alsoo 12.1. I´m using Windows 10, isn´t it problem?
Altera_Forum
Honored Contributor I
47 Views

Problem solved. Choosen directory from Eclipse must be set to directory, where is actual project. Thank you for your advices :)

Reply